Jetson Xavier NX Developer Kit unable to detect RTC module with i2cdetect

I am trying to use RasClock, with NXP PCF2129AT chip, to be able to accurately read the date/time even when the Jetson Xavier NX is powered off for some time period. However, when I have tried to see whether the RTC module can be accessed or not using the sudo i2cdetect -y -r 1 (or 0) no new devices show up. I have tried to use the normal connection pins of the module and even tried to connect it with jumper cables from the board but nothing seems to be working. No matter what I have tried I was unable to detect the new device. What do you think is causing this problem? I don’t think it is hardware related but I believe that I am missing a step or two or that the i2cdetect doesn’t always give proper results of connections? Really appreciate any help or feedback.

1 Like

Hi, what do you mean that " read the date/time even when the Jetson Xavier NX is powered off for some time period"? Are you saying to do this when Xavier NX is off? That can not be done since it is in off status.

I have tried to meant to keep the time even when the device is turned off. I want to have a simple RTC capability so that the device time will always be correct even after being turned on after some time. So, when the device powers back on, say after 3 days, the correct date/time should be acquired from the RTC module.

To keep time when Xavier is off, you should add a battery or super capacitor to BBAT (J3, like CR1225 battery) on board.

Can’t I use a RTC module like the Rasclock to act as a RTC as I have mentioned? So you are saying that the only option available is to solder a battery connector to the developer kit and use a battery to enable RTC capabilities of the board?

Just got what you mean. Of course you can use a RTC module for this. So the problem is you can’t read the RTC device with Xavier NX, right? Have you check the requested voltage level of RTC device? It should match that of the I2C you chose. Also you can use oscilloscope to observe if the I2C ports output the waveform as you wanted to make sure it sends out correct I2C command to device.

Yes, I can’t read the RTC module with Xavier NX. I have checked the voltage levels and they match, I have also checked the voltages from both the battery and the pins of the module and everything seems fine. Sorry but I don’t have an oscilloscope to be able to check the waveform. Is there any other way to check the connection?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.