Jetson Xavier NX Developer Kit wifi module issue

Hello!
There is some problem with wifi module Azurewave AW-CB375NF from Jetson Xavier NX Developer Kit. Module is configured in AP mode. I connected to the system AP and then start SSH session. Some commands have delay in responses about 10 seconds. For example, if I run watch -n1 date, the printed time not updated every second.
When I swap module to Intel 8265NGW the problem is disappear. Because of this, I think the problem is one of the following:

  • faulty kernel driver
  • faulty module hardware
  • wrong configuration

Is it possible to solve the problem without replacing standard Developer Kit wifi modules?

JetPack version is 4.5.1
I have tested 4 Developer Kits and they all have this problem.

Probably need to consult with the wifi chip vendor.

I used NetworkManager for managing AP. NetworkManager uses wpa_supplicant as wifi subsystem backend. I tried to turn off NetworkManager Wi-Fi management and use hostapd for AP. With hostapd all works fine.
So solution is to use hostapd instead of wpa_supplicant for AP.

There is another solution :)
I tried compile from source latest wpa_supplicant 2.9 (system default is 2.6) and install it with checkinstall tool. Now AP works fine also with NetworkManager.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.