Jetson Xavier NX fan problem

In recent days I have fan problem:
Sometimes, not always, when system updating, or some software installing or starting the board, the fan is running at full speed and make much noise.
I checked the /etc/nvfancontrolconf file:


And I also typed the command $ sudo nvfancontrol -q
FAN1: FAN_CONTROL: open_loop
What’s the problem? Please help me. Thank you.
I am using Jetson Xavier NX Developer Kit and ubuntu 20.04 with JetPack 5.0 flashed by sdkmanager gui.

For the fan issue, you better dumping the temperature info from tegrastats directly. Anything described from you may not be as precise as temperature info.

Last time we had another user said his board is hot but fan does not spin. Turns out it is only 40C.

Also, we are not sure if this is jp5.0 new issue. You can try jp4.6.1 on same board and see if it will hit issue.

Thank you for your prompt reply.

I have used the board with JetPack 4 for a long time and it hardly had such a fan problem. I think it is not the temperature which causes the problem because this happens irregularly.

I could not give up JetPack 5 now since it has many advantages.

How can I find a way to temporarily stop the crazy fan? (I tried “stop nvfancontrol”, but useless)

You can directly modify the pwm value.

Thank you, I will try it when the fan becomes crazy.

I’ve also faced the same. The workaround has been:

sudo systemctl stop nvfancontrol.service
sudo rm /var/lib/nvfancontrol/status
sudo reboot
1 Like

Is there any specific method to reproduce this issue?

Or it is a random one?

It was always using slow fan for early boot, and when linux starts it was always running at 100%. Probably reinstalling the /var/lib/nvfancontrol/status file would reproduce it, but I’ve deleted it… I can say that using:

sudo systemctl stop nvfancontrol.service
sudo rm /var/lib/nvfancontrol/status
sudo systemctl start nvfancontrol.service

was stopping fan after 2 seconds, but it was wrong again after next boot.
Seems shutting down with service off did the trick, but why is still obscure to me.

The workaround may only work for reboot, but not for poweroff.

Sorry that we still not able to reproduce this issue locally.

If you have the exact steps to reproduce, please let us know.

I can’t provide a way to reproduce that without sending my devkit, but here is my serial boot log:
NX-jP5.0.1-FAN issue - Serial Boot log.txt (66.8 KB)


  • Flashed to NVME SSD
  • 5 to 10 seconds of void scolling when UEFI boots
  • test kernel in extlinux is a JP4 config test. Not used here.
  • When MB2 or UEFI starts (not sure which one) the fan starts at low speed.
  • When Linux boot terminates :
[    9.460055] using random self ethernet address
[    9.460200] using random host ethernet address
[   10.344528] using random self ethernet address
[   10.344687] using random host ethernet address

the fan runs full speed. In most cases, it slows down after 2 seconds. But in some cases it stays full speed. Then I have to log in and issue:

sudo systemctl restart nvfancontrol.service

to have it back to slow.

It fails more frequently after cold boot, and even more after several days off.

In case this helps.

Sorry that we’re still not able to reproduce this issue locally by following your steps.
Not sure if that’s the FAN issue, suggest to do the RMA if still in warranty.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.