Jetson Xavier NX Gstreamer nvv4l2h264enc h264 AUD unit comes all-time

I’ve used Jetson Xavier NX built in Gstreamer encoder - nvv4l2h264enc and built a pipline using it-
gst-launch-1.0 nvarguscamerasrc name=nvarguscamerasrc0 ! ‘video/x-raw(memory:NVMM), width=(int)640, height=(int)480,
format=(string)NV12, framerate=(fraction)30/1’ ! nvv4l2h264enc ! h264parse ! filesink location=normal.h264 -e

Analyzing the dump i’ve found AUD unit is coming in the h264 dump.
But with gst-inspect-1.0 nvv4l2h264enc it says
insert-aud : Insert H.264 Access Unit Delimiter(AUD)
flags: readable, writable
Boolean. Default: false
Then i’ve tried building a pipeline with insert-aud=false
gst-launch-1.0 nvarguscamerasrc name=nvarguscamerasrc0 ! ‘video/x-raw(memory:NVMM), width=(int)640, height=(int)480,
format=(string)NV12, framerate=(fraction)30/1’ ! nvv4l2h264enc insert-aud=false ! h264parse ! filesink location=audfalse.h264 -e

But still AUD unit is coming. How can i turn off the AUD unit?

Hi,
Thanks for reporting it. We can observe the issue on r32.4.3. Will invstigate and update.

Hi,
The AU delimiters are inserted by h264parse. You can try the pipeline without it:

$ gst-launch-1.0 videotestsrc num-buffers=300 ! nvvidconv ! nvv4l2h264enc ! video/x-h264,stream-format=byte-stream ! filesink location=a.h264