Jetson Xavier NX GUI bring up Issue

Hi Team,

We are trying to bring up GUI by using SDK manager build
image but not able to do so. Logs for it is :
anycon@anycon-desktop:~$ ps -aux | grep x11
gdm 6383 0.0 0.2 185656 22580 tty1 Sl 09:37 0:00 /usr/lib/ibus/ibus-x11 --kill-daemon
anycon 18110 0.0 0.0 5672 636 ttyTCU0 S+ 09:54 0:00 grep --color=auto x11

When we tried with prebuild SD card image then it is working finr.
Logs for it is as :
anycon@anycon-desktop:~$ ps -aux | grep x11
gdm 9927 0.0 0.2 184860 21564 tty1 Sl 12:36 0:00 /usr/lib/ibus/ibus-x11 --kill-daemon
root 11865 1.1 0.2 185464 22008 ttyGS0 Sl 13:01 0:00 /usr/lib/ibus/ibus-x11 --kill-daemon
anycon 12252 0.0 0.0 5672 640 ttyTCU0 S+ 13:02 0:00 grep --color=auto x11

Please help we require urgent help.

What are your steps to setup image?

We are following the commands from this link of nvidia:
https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide%2Fflashing.html%23wwpID0E0LG0HA

And what was the base you are using to create sdcard image?

We are using jetson_nx_base_tar_R32.4.3_aarch64.

Hi,
Can you share the exact link or file name from our download center? https://developer.nvidia.com/embedded/downloads

We have downloaded SD card image and SDK from this link for jetson xavier nx:

Hi,

prebuild SD card image then it is working finr.

Then what is this pre-built sdcard image, If official sdcard does not give you gui.

And for official sdcard image, are you able to run gdm3 manually?

The link which i have shared with you above from there i have downloaded SD card image for jetson xavier nx and on this image i am able to bring up GUI.

But when i am trying to bring up GUI from SDK manager build image then i stucked at login. Logging screen is coming again and again even after giving password.

  1. If you just use flash.sh from sdkmanger to flash your sdcard, will you see this error?
  2. Do you ever configure the user account before you hit this error?
  1. yes
  2. no

Then the symptom for this problem is the oem-config GUI is never showing up on your screen.
Have you ever tried rel-32.4.4?

no

Then please try rel-32.4.4. If there is any bug on rel-32.4.3, we will still ask you to try latest release.

ok thanks.

Could you please tell us changes for base code version 32.4.3 to resolve this infinite loop logging issue as we have to do a lot of changes if u try to work on base code version 32.4.4 and it requires more time and we are running late.

Hi,

Actually, I think there is no problem on both rel-32.4.3 and rel-32.4.4 because we don’t have other users reporting such issue with rel-32.4.3. You can try other sdcard or re-install the sdkmanager again.

I also tried rel-32.4.4 on my side and it works fine.