Jetson Xavier NX I2S Configuration

Hi !
We have a LT6911(a hdmi to mipi birdge IC) need to work on master mode and give MCLK to NX, and we connect it to the i2s3 bus of NX,
So we should set NX to slave mode,what parameters should we configure??

Thanks!

Hello!

What is the MCLK you are referring to? Do you mean the I2S bit clock?

The I2S3 can be operated in slave mode by setting …

$ amixer -c jetsonxaviernxa cset name="I2S3 Codec Master Mode" "cbm-cfm"

Alternatively, you can make the configuration of each the I2S interface permanent by setting in device-tree. See “Codec as I2S Master/Slave” in this section.

Regards,
Jon

thanks for your tips, jonathanh. I have tried the command,
1.“I2S3 Codec Master Mode” , Codec Master Mode should be ‘codec master mode’
2. Reference“Codec as I2S Master/Slave”, but we still don’t know how to modify the relevent permanents in device-tree, please give us more specific details,thank you very much !

Another Question : after we use command amixer -c1 cset name=“I2S3 codec master mode” “cbm-cfm” to set I2S3 to slave mode.

Then we below command to set the ADMAIF1, but we still can not capture the Audio from I2S3 …
amixer -c1 cset name=“I2S5 Mux” ADMAIF1
amixer -c1 cset name=“ADMAIF1 Mux” I2S3
amixer -c1 cset name=“n Master Playback Switch” on
amixer -c1 cset name=“n Master Capture Switch” on
gst-launch-1.0 alsasrc device=hw:1,0 ! alsasink

We also tried to use below arecord command to record the audio from I2S3, but still not works, the saved file size is just very small…
arecord -Dhw:1,0 -r44100 -f S16_LE -c 2 -d 5 test.wmv
gst-launch-1.0 alsasrc device=hw:1,0 ! wavenc ! filesink location=test.wav

do you have some ideas to check why we can not record the audio from lt1911 I2S to NX I2S3 ??