Jetson Xavier NX UART J14 block


I’m trying to see the CBoot bootloader section when the kernel is loaded. I read somewhere you can see this using the UART / RS-232 connection with the pins on the J14 block.

I’ve connected to the Xavier NX via serial cable and use PuTTY from a Win box but just get junk out. I’m using 115200,8,N,1 for the serial settings. I’ve used different speeds, checked language encoding, and ensured my cable is working with another device but nothing seems to work. I’ve read though many articles but none seem to address the issue. One guy said he just swapped a TTL cable for a USB cable and that worked. I don’t understand why this is not working with a standard serial cable.

moving this topic to Jetson Xavier NX,

hello edward.dow,

it seems lots of scrambled contents according to Jetson Xavier NX how to use the UART J14 port - #11 by edward.dow
instead of using [J14], 12-pin button header; could you please try [J12], 40-pin expansion header to connect pin-8/10 for confirmation.

I will also switch any replies to this thread.

I am wondering if your UART cable is using a 3.3V logic level. Can you verify the UART side of this is 3.3V on your setup? Either by specification or by oscilloscope would do.

Jerrry –
Tried using the 40 pin header and get absolutely nothing. Both Putty and SPU utilities. In SPU I tried switching from TEXT to HEX as well and there is nothing being sent.
Also, swapped the TX and RX just to make sure I had them connected properly.

linuxdev…so you may be onto something… checked with oscilloscope

PC serial port is communicating at 5V

Jetson is communicating at 3.3V

Searching for a level shifter to verify this is the problem.

A coworker of mine helped me with a level shifter. He says the Jetson is using 3.3v CMOS logic and the PC serial port is using 5v TTL logic. So basically he came up with a device to convert between the two. Now everything is working and I can see the boot menu when it boots up.

Thank you linuxdev and Jerry for all the troubleshooting suggestions!