Jetson Xavier Wireless and Wired Internet Connection Issues (Solved)

Hi, so I’ve run into an issue with the Jetson, by default many things are disabled, flashing it via Jetpack and using it doesn’t provide everything you need, most things like V4L2 and wireless drivers I had to install and compile myself, but I did have to compile them as part of the kernel and not modules. Anyways the issue i’m having is I finally got Ethernet into the room i’m working in and can now plug it into the Jetson correctly, the issue is when I use wireless or ethernet and run a speed test, the Jetson looses it shit, the speed results I get back are:
Download 1.82 Mbps and Upload 9.05 Mbps … I mean A, upload should not be better than download here, B, my PC caps at 60 so this clearly shouldn’t be an issue.

After some thinking the only thing I can think of is either my kernel is messed up and it could be, or the Jetson is missing key kernel options that don’t come with 4.9.
As a heads up this is the program I have been using to reflash it. https://github.com/jtagxhub/jetpack-agx-build

Another issue is for some reason most devices can’t be detected and show up as USB0 and considered to be Ethernet devices, and that makes no sense…

And Chromium is also very oddly slow compared to the TX2.

So i’m loosing my mind slowly, if anyone would be willing to help me, I would appreciate that very much. Also I have a document in my github repo that explains how I did some stuff.

Actually could be this

echo "options iwlwifi 11n_disable=8" | sudo tee -a /etc/modprobe.d/iwlwifi.conf

I don’t know enough about wireless config to know what this would do, but I did see something interesting which might be useful (or might not be useful):
http://cachestocaches.com/2016/1/disabling-ubuntus-broken-wi-fi-driver/

That article seems to be basically what you are finding.

FYI, the USB0 device is just a demo of the “gadget” interface for emulating devices on a USB connector in “device” mode.

enabling mode 8 on the iwlwifi fixed the issue, what is the gadget mode? Also should I disable the bridge that it creates the l4tbr0?

@rafcin.s were you able to build v4l2loopback module?

I have not tried but let me take a look

the module allows to use devkit onboard csi mipi camera for video conferencing purpose through chromium as a generic web-camera

i’ve mounted the CSI camera, that explains why it doesn’t work, is it in the 4.9 Kernel, if so I can boot into ubuntu now and compile it.

@rafcin.s: it actually works, try with

gst-launch-1.0 nvarguscamerasrc ! 'video/x-raw(memory:NVMM),width=1024, height=768, framerate=120/1, format=NV12' ! nvvidconv flip-method=0 ! nvegltransform ! nveglglessink -e

source: https://elinux.org/Jetson_TX1/TX2_OV5693
but for the web camera mode the additional loopback module is required