Jetson Xavier won't enter recovery mode

I was using a Jetson Xavier to control a robot. It worked well until today it won’t boot up. I was using it one day ago and it worked well. I tried to reflash it but I couldn’t make it enter recovery mode. I pressed the force recovery button and power it up. I connected the recovery USB port to a Ubuntu computer (not VM) using a USB3 cable. The ‘lsusb’ didn’t list the ‘NVIDIA Coorp’ device. I checked the dmesg, there is no message related to Nvidia. I have tried three different USB3 cables, none of them worked, so I don’t think it’s the cable issue. The USB serial port can be detected by the host computer, but no message was received.

It sounds like an actual hardware failure, but do you have a different Ubuntu PC host you can use the supplied cable with in order to see if it is related to the connector itself, and not the cable? You might also examine connectors for any damage.

I tried another computer with Ubuntu 16.04. Same results, not detecting Jetson. I checked the PCB board. I didn’t see any visual damage or any chip burnt. It’s very weird, it was working one day ago. Initially, I thought the button might be broken, but I checked the button with a multimeter and it’s good. How do I check if it’s the connector is damaged?

I’m not sure about connector testing (other than something like a USB analyzer). I am thinking this is an actual hardware failure in the carrier board. Someone from NVIDIA may need to suggest another way to test to verify one way or another, e.g., perhaps there are test points a voltage can be measured across on the actual circuit board downstream from the recovery mode button to see if voltage changes on recovery button press.

Yes, I checked the schematic of the carrier board. There is one pin on the automation header to indicate the recovery button being pressed. I checked that pin and the recovery button is working properly. I also suspect it’s a hardware failure. So can someone from Nvidia tell me how to file a RMA? Thanks in advance.

Hard to say what it is, but your original issue “it won’t boot up” is sort of symptomatic of a failure that’s preventing the Tegra from running, in normal or forced recovery mode. If you connect the HDMI and turn it on, do you see the Linux boot console. Or you can use one of the two tty to get a login prompt from getty after a minute of so. If neither one of those things happen, seems fried.

No, it won’t boot up. That’s why I want to reflash the system. I didn’t get any boot up message from tty either. I guess it’s dead now but I couldn’t think of why.

Normally you would RMA through your supplier. You can follow this and find out more though: