JP 5.0.2 custom board flashing - missing L4TConfiguration.dtbo

I try to flash custom board with JP 5.0.2 jetson-xavier-nx-devkit-emmc conf file.
The flash process fails with error: FileNotFoundError: [Errno 2] No such file or directory: ‘L4TConfiguration.dtbo’
Failed flashing t186ref.

flash log:
flash.log (33.6 KB)

What is this file and why its missing? I followed the kernel customization procedure as described in r35.1 dev guide.



If you directly flash sdkmanager, will it report error?

I didn’t try it and only if it’s possible I prefer not to install the sdkmanager right now (minor free space problem).
Can we try handle this issue without it?
(If not I’ll make some changes and install it)


Hi BSP_User,

Do you have below file?

No. I didn’t find it in the “Out” folder nor the Linux_for_Tegra.
That’s what troubling me. I used the given sources and followed the kernel customization procedure (using the and didn’t find it anywhere…

I have the same issue and and the file Linux_for_Tegra/kernel/dtb/L4TConfiguration.dtbo is present.
I observed that the same file is being added to JP 5.0.2 and is not present with any older releases.


Are you saying that even you have that dtbo file in your folder and you still hit same error? Could you also share your log?

Hi Wayne, find the below attached flash log.
JP35.1_flash.log (33.2 KB)

Could you share the file list of your kernel/dtb?

list.txt (6.7 KB)

An Update.
I am using a custom build path with my custom images. I manually copied some of the L4T* files from kernel/dtb into my custom build path and was able to resolve this issue.
I would like to know why these files were added and what’s the purpose?


Could you clarify more about what you’ve done to make it work?

I have a custom build patch which has kernel images, rootfs and dtb’s. While flashing with my custom board, it looked for ‘L4TConfiguration.dtbo’ in my custom BUILD path and was not available in the given path. I had to manually copy these file into my custom BUILD path and got it working.

Sorry, does your “custom build” mean another BSP folder?

So actually there was no L4TConfiguration.dtbo there and the file is missing ?

I feel we are asking about A but you are tell me something about B…

Can you write the commands you’ve executed which result with the L4TConfiguration.dtbo creation?

HI BSP_user,

What is under your Linux_for_Tegra/kernel/dtb$?

How did you prepare this BSP folder? If you use the one from sdkmanager, will you see that file?

Yes, usually nvidia takes build images from Linux_for_Tegra/kernel/; But in my case it is from a different path. My issue was missing files and if I copy that file to my path it worked.
The issue could be different for BSP_user.

  1. kernel/dtb files:
    files.list (11.2 KB)

  2. Prepare steps:

    1. Downloaded the sources from here: Jetson Linux 35.1 | NVIDIA Developer
    2. Extracted Linux_for_tegra and rootfs sample into Linux_for_tegra/rootfs
    3. Extracted kernel sources into Linux_for_Tegra/source
    4. Executed ./ -o $PWD/kernel_out
    5. copied $kernel_out/drivers/gpu/nvgpu/nvgpu.ko into specified directory in the dev guide
    6. Replace the files in Linux_for_Tegra/kernel/dtb/ with a copy from:
    7. Replace Linux_for_Tegra/kernel/Image with a copy of this file:
    8. Executed
    9. Flashed using ./
  3. what do you mean by “If you use the one from sdkmanager, will you see that file”?
    use with what?

Sdkmanager will also download a BSP folder to your host machine. So you don’t need to prepare the BSP by yourself ( this is what you are doing now)

I wish to do it by myself since I need to customize it. Before I’m doing that I want to see if the flashing process succeed without any changes