JP 6.0 Orin AGX 32g DevKit Backup_Restore Error

Hi,

JP6 install went flawlessly and I’d like to snap a baseline recovery image of the system after getting set up for Isaac/ROS2 development.

Following instructions in README_backup_restore.txt after reading tips at:
https://forums.developer.nvidia.com/t/l4t-backup-and-restore-doesnt-work-since-jetpack-5-1-2/268638/3cd

I run from ./JetPack_6.0_DP_Linux_DP_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra:
$ sudo ./tools/backup_restore/l4t_backup_restore.sh -e mmcblk3 -b jetson-agx-orin-devkit

and get (no joy):


Waiting for target to boot-up…
Waiting for target to boot-up…
Waiting for device to expose ssh …RTNETLINK answers: File exists
RTNETLINK answers: File exists
Waiting for device to expose ssh …Device has booted into initrd. You can ssh to the target by the command:
$ ssh root@fc00:1:1:0::2
Cleaning up…
Log is saved to Linux_for_Tegra/initrdlog/flash_1-2_0_20240323-212750.log
Run command:
ln -s /proc/self/fd /dev/fd && mount -o nolock [fc00:1:1::1]:/vol/Downloads/Downloads/developer.nvidia.com/JetsonNX-poc/JetPack_6.0_DP_Linux_DP_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra/tools/backup_restore /mnt && /mnt/nvbackup_partitions.sh -e mmcblk3 -n && echo Backup image is stored in /vol/Downloads/Downloads/developer.nvidia.com/JetsonNX-poc/JetPack_6.0_DP_Linux_DP_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra/tools/backup_restore/images
on root@fc00:1:1::2
nvbackup_partitions.sh: The detected partitions in mmcblk3 are:
/dev/mmcblk3p1
/dev/mmcblk3p2
/dev/mmcblk3p3
/dev/mmcblk3p4
/dev/mmcblk3p5
/dev/mmcblk3p6
/dev/mmcblk3p7
/dev/mmcblk3p8
/dev/mmcblk3p9
/dev/mmcblk3p10
/dev/mmcblk3p11
/dev/mmcblk3p12
/dev/mmcblk3p13
/dev/mmcblk3p14
/dev/mmcblk3p15

nvbackup_partitions.sh: Backing up QSPI0…
flash_to_file: read, size 0x4000000, n 0x4000000
read(): Input/output error

I do also have an M.2 SSD, /dev/nvme0n1 mounted at /ssd/ as recommended in the setup for docker, if that’s possibly a factor.

What have I done wrong or would you recommend to get a recovery image I could restore later?

Thanks!!

This workflow is currently broken on JetPack 6.
There is some issue with the QSPI driver and we are investigating it.
You can consider this as a similar way for backing up:
https://docs.nvidia.com/jetson/archives/r36.2/DeveloperGuide/SD/FlashingSupport.html#cloning-a-jetson-device-and-flashing

That seems to have worked for my use-case/workflow, successfully cloned and restored the APP partition.

Didn’t have to change the allocation_attribute of the APP partition (it was already set to 0x808) but still need to confirm it is max-size. Haven’t used this approach since early TX1/2 days, glad to see it still works.

Seems a bit odd that backup_restore doesn’t see emmc as /dev/mmcblk0p1 while flash.sh does. In the live system, the partitions appear at /dev/mmcblk3p* (with p1 mounted on /) which is what backup_restore also apparently sees.

Looking forward to having more up-to-date 22.04 and native ROS2 Humble/Rolling.

Many Thanks!

Sure, glad it worked!

We will change the naming back to mmcblk0 on JetPack 6 GA.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.