JP 6.0 RT_Patch Flash Issue with Initrd

@DaveYYY Let me give it one more shot by using new SSD and starting from scratch on stock.

YES. That’s how debug works.
You don’t make a lot of changes at a moment and get lost in the real cause.

1 Like

@DaveYYY Still no luck, please help. Tried to use different machine with fresh new VM install, new SSD, but flash was unsuccessful.
Tried with script sudo ./flash.sh jetson-agx-orin-devkit nvme0n1p1 but still no luck.

What version of SDKMANAGER did you try with ?

serial_log.zip (19.2 KB)

Don’t use virtual machines.
Maybe the kernel image and initrd are not even flashed into the device, so it just tried normal booting.

This is never going to work.

@DaveYYY What changed, I used VM for Jetpack 5 series and built rt patch with no issues and flashed on NVMe except for display driver in that case.
Also Jetpack 6 DP was successful building and flashing using USB 2.0.

Its timing out to connect after target to boot up during flash, the script I am using to flash on NVMe is,

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -p “-c ./bootloader/generic/cfg/flash_t234_qspi.xml” -c ./tools/kernel_flash/flash_l4t_t234_nvme.xml --showlogs --network usb0 jetson-agx-orin-devkit nvme0n1p1

Can you check with team and I think this could be resolved ?

I have said, don’t use virtual machines.
We never claim that virtual machines are supported for flashing Jetson devices.
Unless you can handle all the USB connection tricks.

@DaveYYY Respectfully, can you try on VM ? Or check with team ? As there is no issue flashing to internal memory with same VM and there are not much tricks to USB except filtering and auto connect.

At this part of flash, the device never shows up in the lsusb side either ,

NO.

I think I have been very/super clear on this.
We don’t support VM nor do we deal with issues regarding flashing with VM.
That’s my only answer.

Or do you need me to reiterate in other languages?

Or if you do have difficulty getting a Linux PC, consider WSL and read this post:

That’s the only way that we have verified, though still not recommended.

@DaveYYY AS per your suggestion WSL worked with stock kernel on NVMe as first step and should be good for bringing my previous build of kernel 6.1. Thank you for support.