Jtop can't run on custom carrier board

Hi,
Recently when we install jetson-stats for jtop, jtop keeps showing error as below.

The jetson_stats.service is not active. Please run:
sudo systemctl restart jetson_stats.service

After check, we think the reason of no jtop.service is becasue we didn’t have a fan control on our carrier board.

[INFO] jtop.core.common - fan loaded on /sys/devices/pwm-fan/
[INFO] jtop.core.common - jetson_clocks loaded on /usr/bin/jetson_clocks
[INFO] jtop.core.common - tegrastats loaded on /usr/bin/tegrastats
[INFO] jtop.main - jetson_stats server loaded
[INFO] jtop.core.fan - Mode set default status=False
Process JtopServer-1:
Traceback (most recent call last):
File “/usr/lib/python2.7/multiprocessing/process.py”, line 267, in _bootstrap
self.run()
File “/usr/local/lib/python2.7/dist-packages/jtop/service.py”, line 188, in run
self.fan.initialization(self.jetson_clocks)
File “/usr/local/lib/python2.7/dist-packages/jtop/core/fan.py”, line 166, in initialization
self.set_mode(mode, False)
File “/usr/local/lib/python2.7/dist-packages/jtop/core/fan.py”, line 197, in set_mode
self.auto = not status
File “/usr/local/lib/python2.7/dist-packages/jtop/core/fan.py”, line 267, in auto
with open(self.path + ‘temp_control’, ‘w’) as f:
IOError: [Errno 13] Permission denied: ‘/sys/devices/pwm-fan/temp_control’
[INFO] jtop.service - Service closed

We ever ran an earilier version of jtop on our carrier board. Could you fix this problem?

hello m0920222982,

assume you’re having software update to the latest JetPack release version.
FYI, it’s now using hw monitor to control the fan tachometer.
for example,

$ cat /sys/class/hwmon/hwmon*/name
thermal-fan-est
pwm_tach
tegra_pwmfan

$ cat /sys/class/hwmon/hwmon2/temp_control
1

Hi Jerry,
We’re using JetPack4.4

This is my result

root@linux:~# cat /sys/class/hwmon/hwmon*/name
thermal-fan-est
pwm_tach
root@linux:~# cat /sys/class/hwmon/hwmon2/temp_control
cat: /sys/class/hwmon/hwmon2/temp_control: No such file or directory
root@linux:~#

Hi @m0920222982,

I read now your message. I fixed yesterday this bug from https://github.com/rbonghi/jetson_stats Today I will release the new version to fix your bug.

I would like to know if you can share using the permissions and files from /sys/devices/pwm-fan/

Can you run and share the output of this command:
ls -l /sys/devices/pwm-fan/

If you have other issues on jetson-stats or jtop write an issue on this repository: https://github.com/rbonghi/jetson_stats/issues

Hi @JerryChang , why are you suggest to check the folder /sys/class/hwmon/hwmon?
From jetson_clocks the fan folder is located in /sys/devices/pwm-fan/

I just release a new jetson-stats v3.0.1, it should fix this bug, keep me posted if you have other issues.

To update write in your shell:
sudo -H pip install -U jetson-stats

hello rbonghi,

you’re correct,
jetson_clocks control the fan and setting PWM values via the fan folder i.e. /sys/devices/pwm-fan/;
hardware monitor, i.e. /sys/class/hwmon/hwmon were user-interface for checking all settings.

please also note that,
starting with l4t-r32.4 release, jetson_clocks no longer set the maximum fan speed by default.
you should specify --fan option to sets maximum PWM fan speed as old behavior.

you may also refer to Maximizing Jetson TX2 Performance and also Fan Speed Control session for more updated info. thanks

1 Like

Hi rbonghi,
Yes, the new verson 3.0.1 fix the problem, thanks.
Here is the output for the command

root@linux:~# ls -l /sys/devices/pwm-fan/
total 0
-rw-r–r-- 1 root root 4096 Jul 27 06:17 driver_override
-r–r--r-- 1 root root 4096 Jul 27 06:17 modalias
lrwxrwxrwx 1 root root 0 Jul 27 06:17 of_node -> …/…/firmware/devicetree/base/pwm-fan
drwxr-xr-x 2 root root 0 Jul 27 06:17 power
lrwxrwxrwx 1 root root 0 Jul 27 05:25 subsystem -> …/…/bus/platform
-rw-r–r-- 1 root root 4096 Jul 27 05:25 uevent
root@linux:~#

1 Like

hi:
How do I control the TX2 fan?
Here is the output for the command
root@MSD:/sys/devices/pwm-fan# ls -l /sys/devices/pwm-fan/
total 0
-rw-r–r-- 1 root root 4096 9 18 06:10 driver_override
-r–r--r-- 1 root root 4096 9月 18 06:10 modalias
lrwxrwxrwx 1 root root 0 9月 18 06:10 of_node -> …/…/firmware/devicetree/base/pwm-fan
drwxr-xr-x 2 root root 0 18 06:10 power
lrwxrwxrwx 1 root root 0 1月 28 2018 subsystem -> …/…/bus/platform
-rw-r–r-- 1 root root 4096 28 2018 uevent
No target_ PWM file how can I control the fan ?