JTSON ORIN no screen


I have an issue when trying to turn on jetson Orin.
it just does not turn on after rebooting, it is known to have such an issue,
what can be done about this? Do I need to download anything to the UEFI bootloader?
How can I do that?

Best Regards

Moving this from the Virtual GPU to the Jetson Orin category.

Have your Jetson Orin been reflashed with SW by SDK manager before?

Yes, we tried formatting the sd card multiple times and SDK manager does not recognize the Orin
we are currently trying to flash it, do you have any recommendations to do that?

Best Regards

What does that mean you format the sdcard multiple times? Orin AGX does not support to boot from sdcard image.

There is no sdcard image for Orin either.

In any way, the device did not boot up after that it shown a lack of memory on ROM and started making issues with compilations
saying that there is no space in /tmp so I rebooted it and it did not turn on.
What can we do?


Please use another x86_64 ubuntu 18.04 host, put your jetson Orin into recovery mode, flash it with sdkmanager.

I don’t know what you followed, but your previous way to set up device sounds incorrect.

I have tried so far 2 different hosts.
I can try using virtual machines, I will try one more.
Do you recommend flashing firmware UEFI will solve it?
Also we have the same issue on nx215, How can we flash it?

Hold on here please. Could you clarify what have you tried exactly? I feel we are not talking about the same thing here.

Also, sdkmanager does not support VM.

And sdkmanger is flashing the firmware, including the UEFI.

Ok, I will try and update you.

Try what? Could you clarify your situation first before trying? This will save your time.

What did you try before? And what was the result of your previous try?

Again, My Orin did not turn on after a reboot.
it showed errors like lack of space on /tmp making compilations an issue
you recommended using a given manual to solve the issue.

Ok, so you didn’t flash with sdkmanager before? I just don’t understand what does that mean you tried 2 hosts.

before we tried flashing with SDK manager and it did not recognize the board, I tried this on 2 different Linux x64 PCs.
Currently, I will try using the script specified in https://developer.nvidia.com/embedded/learn/get-started-jetson-agx-orin-devkit

Sorry that I misled you again. What your understand is still incorrect

We still need you to flash with sdkmanager. Those script from the link won’t work.

Those script is based on the situation that your board can boot up. But currently, you don’t even know whether your board boots up or not. Thus, better flashing it with sdkmanager.

And if sdkmanager cannot work, you need to share the log of sdkmanager so that we can tell why it does not work.

Also, please remember that you need to put the board into recovery mode so that sdkm can flash.

It sounds like you are working with more than one model of Jetson, so I thought I’d add some general notes:

  • eMMC models do not boot from SD card. Attempting to boot this way (except in cases purposely modified) won’t usually work.
  • SD card models (some dev kits, but not the AGX) still need to be flashed because boot content is in QSPI memory on the module itself, while rootfs is on the SD card. SD card rootfs and eMMC tend to not be interchangeable.
  • The SD card model of Jetson module (the actual module, not the SD card) flash is only via JetPack/SDK Manager (there are command line options, e.g., flash.sh).
  • If the QSPI content of the SD card model is too far off in release version versus what is on the SD card for rootfs, then boot will probably fail. A range of SD card rootfs releases work with one release of QSPI content, but this sometimes changes; it is safer to just flash the Jetson with JetPack/SDKM the first time you create an SD card image if it fails.
  • The reason a VM is not supported for the host PC is that VMs do not normally handle USB correctly for devices which disconnect and reconnect in the middle of operation. A Jetson will disconnect and reconnect during flash, and if the VM loses the USB, then it fails. It is possible for a VM to work, but USB is something custom to the VM and not something the Jetson software can support (you’d have to learn to keep USB at all times on your VM, and each VM brand is different for this).
  • This is the “gist” of flashing:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.