Junk data on uart 1( j17 header)


I executed following command in terminal in ubuntu

echo aa > /dev/ttyTHS2

Im getting junk data in teraterm which is connected to j17 header through TTL/232 uart.

What is the baudrate ?? i tried all baudrates available. but still not getting proper data.

also I’m not getting data when I connect tx to rx…


hello shrinathchoudhary,

the default baudrate is 115200/8n1,
could you please have a try to having getty on background.
for example,

$ sudo /sbin/getty -a ubuntu -L 115200 ttyTHS<port> &)

please also check similar discussion thread, Topic 1062786 for reference.


It is not working

im getting junk data baudrate less than & equal to 115200

J17 itself is normally open for use, but if you have something using the serial UART to the camera port of the dev board, then there may be other traffic. The default camera the dev kit comes with does not touch this port, but a custom camera might.

J17 should be 115200 8N1. If there is noise with this, then describe your cabling. Is it shielded? Twisted pair? Short? Long?