Kapao_s_coco.pt to engine, When jetson NX uses tensorrt acceleration, it prints incorrectly, and it runs normally on x86

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) jetson
• DeepStream Version deepstream6.0
**• JetPack Version (valid for Jetson only)**jetpack4.6
• TensorRT Versiontensort8.0.1.6
**• NVIDIA GPU Driver Version (valid for GPU only)**cuda10.2
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

The error is as follows:


Reference :
code:GitHub - wmcnally/kapao: KAPAO is a state-of-the-art single-stage human pose estimation model that detects keypoints and poses as objects and fuses the detections to predict human poses.
convert_to_onnx.py (838 Bytes)

step1;
python convert_to_onnx.py --checkpoint-path kapao_s_coco.pt
step2:
trtexec --onnx=kapao_s_coco.onnx --explicitBatch --saveEngine=kapao_s_coco_best.engine --best
step3:
run

but:
Setting CUDA_LAUNCH_BLOCKING=1 can run, but the error is still printed

In addition, the fps is too low(fps=3.8), I suspect that CUDA_LAUNCH_BLOCKING=1 is set to cause the reduction

additional

jetson nano 报错:

We don’t know anything about this model. What is the model’s input and output?

The preprocessor failed.

Is your model NCHW or NHWC?

Are you running with deepstream sample applications? If yes, which one? What is your nvinfer configurations?

Thank you for your attention

problem solved

step:
os.environ[‘CUDA_LAUNCH_BLOCKING’] = ‘1’
and
scaling-compute-hw=1

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.