Kernel Error in installing Driver 430.09 in Ubuntu 20.04 LTS

So, I had some problems with Nvidia Drivers 440 and 435. I was recommended to use the 430.09, however when installing I’m getting the error “An error occurred while performing the step: “Building kernelmodules”. See /var/log/nvidia-installer.log for details.”. You can see the log here https://paste.ubuntu.com/p/Q3tgwFyJNG/. Any ideas?

PC:
Dell G3 15 3590
NVIDIA GeForce GTX 1650 with 4GB GDDR5 graphics
9th Generation Intel Core i5-9300H (8MB Cache, up to 4.1 GHz, 4 cores)
8GB 2x4GB DDR4 2666MHz

The 430 driver is outdated and incompatible with a 5.4 kernel. Rather install the latest driver and try to fix the issues you’re having with that.

1 Like

So, the problem with the newest driver is that there is a loading symbol from the dell loading screen that freezes in my screen. The system boots normally, but there’s this loading symbol flickering, see: https://i.stack.imgur.com/aLnEM.jpg. Curiously, the symbol doesn’t appear when I take a print screen.

Edit: Also, even with the 440 proprietary driver, if my grub does not have the “nomodeset” line, the system doesn’t boot.

Please run nvidia-bug-report.sh as root with the 440 driver installed and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

Here is the log https://paste.ubuntu.com/p/hygJjFGDq2/

I need to say, however that I installed the 440 driver, booted, and the loading symbol is not freezing anymore. I booted another time to make sure, and looks like my problem was solved. But i really don’t know how hahaha. So, if you take a look to my log and found something problematic, let me know. But, i guess eveything is working good now. Thank you.