Kernel not executed

what might be the causes that the kernel is not executed?
I’m using driver API not runtime API in cuda programming
I made sure of memory transfers and parameter passing but the output is not changed according to the changes in the kernel
any help?

could you provide your kernel?

and do you check run-time API?

I also use driver API, and if you have set correct execution configuration,

then kernel should work, same as using runtime API.

thanx a lot for your concern
the program i am writing is to find the intersection between two lists…i wrote it in run time and everything went fine but when i tried to convert to driver API because i want to do other functionality using C++ it didn’t work…i just opened the matrix multiplication driver version of the SDK and did some modifications according to my functionality…no errors are being generated its just that no modifications are done to the output
i tried minimizing the kernel code but again no results are found… i feel that it’s either the way am launching the kernel or copying the result back to host…i tired all possibilities but nothing changed…
here is the code…i hope you can find anything
thank you
matrixMulDrv.rar (2.64 KB)

disable “findModulePath” in function initCUDA


	// first search for the module path before we load the results

	if (!findModulePath ("../matrixMul_kernel.ptx", &module_path, argv )) {

	   if (!findModulePath ("../matrixMul_kernel.cubin", &module_path, argv)) {

		   printf("> findModulePath could not find <matrixMul_kernel> ptx or cubin\n");

		   status = CUDA_ERROR_NOT_FOUND;

		   goto Error;


	} else {

	   printf("> initCUDA loading module: <%s>\n", module_path);


	status = cuModuleLoad(&cuModule, &module_path[0]);



and replace it by

// executable file is in directory /release

		status = cuModuleLoad(&cuModule, "../matrixMul_kernel.cubin" );

function “findModulePath” uses utility function cutFindFilePath

which is in /SDK/C/common/src/cutil.cpp

You should avoid using any functions in cutil.cpp