Keyboard and mouse doesn't work after flashing Jetson TX2

I’m trying to flash a Connect Tech’s Rudi Jetson TX2 device with JetPack 3.3.

I’ve tried the router and local DHCP connection options, but everytime the flashing ends up in this:

[ 167.4932 ] [................................................] 100%
[ 167.5554 ] 
[ 167.5554 ] Flashing completed
[ 167.5556 ] Coldbooting the device
[ 167.5586 ] tegradevflash_v2 --reboot coldboot
[ 167.5616 ] Bootloader version 01.00.0000
[ 167.5690 ] 
*** The target t186ref has been flashed successfully. ***
Reset the board to boot from internal eMMC.

root      4762  0.1  0.0 527680  3216 ?        Ssl  15:39   0:00 /home/me/JetPack-3.3/_installer/sudo_daemon -installer=4631 -d=/home/me/JetPack-3.3/_installer/tmp
0
/home/me/JetPack-3.3//_installer/run_command  -c="mv /home/me/JetPack-3.3/64_TX2/Linux_for_Tegra/rootfs/etc/rc.local.original /home/me/JetPack-3.3/64_TX2/Linux_for_Tegra/rootfs/etc/rc.local" -d=/home/me/JetPack-3.3//_installer/tmp
1
Finished Flashing OS
Determining the IP address of target...

It always get stuck on determining the IP address. Should it continue and do something?

I can boot the device to Ubuntu, but connecting USB mouse and keyboard doesn’t work. They worked before flashing on the same device.

How can I solve this?

<< DELETED >>

FYI, prior to this it looks like flash succeeded. Flash uses recovery mode over the USB connection. Once flash completes the Jetson reboots and starts using wired ethernet. The usual mechanism provides a way for the Jetson to give a hint to JetPack about what IP address is used upon first reboot (but not upon later reboots). You can look at the console and it may be offering you a chance to manually enter the IP address.

Be aware that you don’t have to always flash, you can uncheck flash and try adding packages at any later date over the wired ethernet. In those cases you’d always manually enter the IP address. You might log in to the Jetson and use ifconfig to find out what the address is. Depending on what you use for a router, then the router might also have a log of what IP address was given (DHCP typically logs when an address request is fulfilled).

Can you log in to the Jetson? If so, this is probably all you need. Without keyboard/mouse that may be an issue, but try CTRL-ALT-F2 to see if a text console is available. Or use serial console.

Beware that alternate carrier boards must use that carrier board’s board support package (BSP). Basically you’d be using the distribution as provided by JetPack, but it would add a modified device tree. You’ll need to consult with that carrier board’s instructions to set that up correctly.

Thanks! I didn’t know about BSP. I now flashed the device with cti-flash.sh by Connect Tech and device recognizes USB devices again:

http://connecttech.com/resource-center/cti-l4t-nvidia-jetson-board-support-package-release-notes/