Keyboard and Mouse Not Working on Xavier

I attempted to execute a cmake build and rebooted, but I still encountered an infinite login loop.
To resolve this, I reinstalled the display manager and chose gdm3.
However, this time the keyboard and mouse input were not working.
I attempted to access the tty terminal, but I couldn’t because the keyboard is not working

What should I do?


What’s this one about? What kind of program are you building?
What L4T/JetPack version are you using?
Is it a DevKit or a custom board?

Hello, DaveYYY,

I am using an NVIDIA AGX Xavier. It’s a Dev Kit.

The basic environment is as follows:
OS: Ubuntu 20.04
CUDA: 11.8
cuDNN: 8.8.0
OpenCV: 4.5.2
JetPack: 5.1.1
L4T: ???

After building a C++ based program and rebooting, I fell into an infinite login loop.

After resolving this error by reinstalling gdm3, I encountered a problem where keyboard input was not working at the login screen.

Then if you login to the system via serial console, plug an unplug your mouse/keyboard, are they detected with dmesg?

I currently do not know how to connect to the serial console.

I do not have a micro USB-B cable. Is there another way?

Have you tried unplugging and plugging the mouse/keyboard at the login screen?

Yes, I just tried that, but it didn’t work.

Is there no other way besides reinstalling Jetpack?

If you don’t have access to serial console, then the only thing I can suggest is re-flashing the device.

1 Like

Thank you. It was very helpful!

Incidentally, the micro-OTG USB connector to the left of the 40-pin header on the AGX Xavier dev kit is the serial console for that model. You’d just plug in the micro-B USB to that connector, watch “dmesg --follow” on the Linux host PC, and plug in the USB-A side to the host PC (the log message should show the names of the serial devices). The first serial device is named when running a serial console program on the host PC with speed 115200, 8 bits, no parity, and one stop bit.

1 Like

Thank you for the additional information! On Windows, I opened a total of four ports by connecting via micro-USB ctype for serial connection. I tried opening the serial console with the settings you mentioned, but there was no response. Does it not work on Windows?

I don’t now if it is COM5 or something else. Serial console does work from Windows, but finding the right setup might be a bit more frustrating. You might try with all of the COM ports.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.