Keyboard and mouse on Tegra do not work on PX2 boot

  1. Before boot, connected USB keyboard & mouse on hub to USB3 Tegra A.
  2. Booted PX2, Tegra screen came up on HDMI
  3. Keyboard and mouse do not work
  4. Tried different keyboards and mice to no avail

If you’ve solved this problem, I’d love to hear from you.

Dear hanford.choy,

Can I know 1. have you changed the USB hub, 2. whether TegraB USB port is available or not? Thanks.

Thank you for your reply.

Yes, TegraB USB port works fine. TegraA does not.

  1. Able to scroll mouse on TegraB, pressing Windows key brings up Ubuntu Search my Computer, can edit files, etc.
  2. Turn off PX2
  3. Plug USB hub into TegraA USB port (immediately below TegraB USB port), change HDMI to TegraA
  4. Turn on PX2
  5. No mouse cursor when moving mouse, pressing Windows key does nothing, as if TegraA is dead or locked up, or USB port is bad.

Brand new PX2 development system.

Thanks.

Dear hanford,
Can you please share your details in a PM. we will look into it.

Hi SivaRamaKrishna,

What is a PM, and how do I create one?

Thanks.

Dear hanford,
PM means private message. My apologies for confusion.

Hi Siva,

How do I create a PM, and who do I send it to?

Thanks.

Hi Siva,

Would you ask someone to look at:

 https://devtalk.nvidia.com/default/topic/1036179/-dev-ttyusb-missing-from-ubuntu-host/#5263658

Because of this problem, we’re total dead in the water and blocked, and cannot flash PX2 with the latest firmware.

Thanks!

Dear hanford,
Yes. We noted this also.

Thanks, Siva! Should be dead simple to get to work. But, isn’t :).

Hi Siva, will you respond directly to my PM yesterday? Thank you

Deae hanford,
Please share board details in private message

Dear hanford,
Can you check if FTDI windows drivers are installed on machine

Dear Siva,

www.ftdichip.com/Drivers/VCP.htm says FTDI drivers are built into Ubuntu 11.10 kernel. So, when I connect USB A-A cable from PX2 Host port to my Ubuntu USB port, /dev/ttyUSB0 - 7 should be automatically created. Please confirm.

Dear hanford,
Can you please check if drivers are installed on windows machine as you said you don’t notice COM ports when you connected PX2. This helps us in investigating furthur.

Hi Siva,

I installed FTDI drivers for Windows 10 from http://www.ftdichip.com/Drivers/VCP.htm. I then rebooted Windows, and inserted USB A-A cable again. Serial ports do not show up in Windows Device Manager.

This ftdichip.com web site says Ubuntu 11.10+ kernels already incorporate drivers for a USB to appear as additional COM ports available to the host PC. Application software can access the USB device in the same way as it would access a standard COM port.

This means my Ubuntu 16.04 release should recognize USB A-A cable with no additional drivers. Is this correct?

I would love for this to begin working by adding a device driver. I’m using a relatively virgin Ubuntu 16.04 I installed two days ago.

Dear hanford,
When you connect to PX2 from windows machine, you should see COM ports like below.

Do you see unknown devices(yellow mark) pop-up in device manager when you connect Host PC and USB 2.0 debug port(not USB 3.0 ports) via USB A-A cable? Can you check with any other USB A-A cable to confirm if it is a hardware issue.

Dear hanford,
Any update here?

Hi Siva,

Our retailer, Autonomoustuff, sent me a known good USB A-A cable, which does not automatically populate Windows Device Manager with the port displayed in your email below.

This definitively tells us:

 USB Host Port is bad, or
 USB driver for Host Port

is bad. Unfortunately, because we cannot upgrade Tegra A/B firmware, we cannot test whether the USB driver for the Host Port is bad. A catch 22.

Does this mean we need to send our PX2 back to Nvidia for repair? Other suggestions to try?

Thanks.
Hanford

Dear hanford,
Just for confirming it further, Do you have any other Drive PX2? If so, can you please confirm, connecting the same to Host PC has no issues.