Keyboard and Mouse unusable on initial startup


We have recently received a Jetson Nano Developer kit (if I am not mistaken the version I have has 4GB of RAM). I have used Balena Etcher to write the most recent image (JP 4.4.1) onto an SD card with the Jetson Nano, however when first loading the device neither the keyboard nor the mouse are detected. I have tried using an earlier (JP 4.3) image to test if the issue persisted but the mouse and keyboard lit up exemplifying that they were functional and had power. However, the start-up seemed to endlessly load after an initial failure (referring to the board setup failure as seen in the image). I know that the image itself may not be able to provide much information, I am using it for clarity.

I can try another, more recent (though not most recent) version of the image in an attempt to see if this helps, though can anyone offer any help with the cause of the USB issue?

Thank you!

hi jay.christopher:
please try methods mentioned below:

Hi Jeffli,

I had a look at the forum though the jetson nano has not been active for a while. Connected only to a HDMI the Jetson Nano (even after formatting and writing the image onto the SD again) is failing to build a connection to the Monitor. A black screen is all I am able to get now. I have looked around other forums though they are little help as the Jetson Nano is also still unable to detect the mouse and/or keyboard. It seems there is little I can do on the device itself as it is not being detected - the monitor is perfectly fine as is the power source. Hope you can help!

Same issue. Please resolve this

I am facing the same issue on a Jetson Nano with eMMc 16 gig storage.

Hi there, to update this forum:

I used a different brand of microSD card (SANDISK worked best for me). If that doesn’t work then ensure your using the correct power terminal (not the microUSB one).

Hope this helps!