Kicked out while calculating...


I wrote a program to simulate long-lasting calculations with OpenCL.
It is basically a vector addition example, with special kernel.
The point was to simulate long kernel calculations (that’s why I used slower int instead of float, long loop and condition checking).
I tried to measure calculation times with 100,1k,10k,100k vector parameters but I’m being kicked out from a program without any error message:
1)On my laptop (GeForce 9300M GS - 8 cuda cores) already from 10k arguments
2)On a cluster from 100k (few old Nvidia cards with 32 cuda cores).

My question is, did I do something wrong with the code? Or OpenCL has some special time limitations?
Source Files:


PS Program is getting vector dimension as first argv parameter, so when you want to run it for 10k parameters you enter:
./a.out 10000

What OS, driver, and SDK are you using?

I use OpenCL on Ubuntu and a long kernel will happily freeze screen updates (X Server) while running, and recover afterwards without any problems. (Although I read somewhere that if the GPU freezes for too long, X will timeout and crash…)

It you are using Windows Vista/7 have you tried disabling Aero, or running it on Windows XP? I’ve read somewhere that Aero screws with the CUDA driver so NVIDIA put some hacks into the Vista/7 driver to get around it. It required that the program do something special, but I can’t remember what.

Also what happens if you run the Kernel on a GPU that is not being used for the desktop? e.g. connect the screen to the motherboard’s integrated GPU and run CUDA on the external GPU.

Another option is to use Linux with X server, or even with out it?