killed GTX280 via softare: is it possible?

I still cannot believe it, but it seems I just killed my GTX280 via software.
I usually run my code on a GTX280 while a GT9500 drives the monitor (ubuntu 9.04, drivers 195.36.24). This configuration runs without problems. For testing I run my code after removing the GT9500, so that the GTX280 drives the monitor and run the CUDA code. I pass which gpu device to use as a command line option. As soon as I executed my code the screen went blank and now the motherboard reports “no VGA detected” at boot. Now my GTX280 is dead.

Is it possible? Any ideas?


Running your code on the GTX280 while it’s also the display card could inded cause your monitor to blank or freeze… the GPU can run CUDA or run the display, but not both at once.

Normally with short kernels the display just freezes and then returns (often causing display stuttering) but it’s easy to go too long. You can also have CUDA bugs that corrupt display memory and that could cause freeze/crashes that wouldn’t happen on a nondisplay card.

But now your interesting question about “no VGA detected.” How does your motherboard report that? Via a BIOS bootup message on the very display it claims it can’t find?

Or by some motherboard LED that’s blinking an error code?

It’s easy in Linux to have a card not found for display, and it will say “using low graphics mode” and complain. This is usually an xconfig problem, and running nvidia-xconfig will often fix it (unless you’re doing fancier games like trying to use a specific card for display that’s not the first default boot display card, then sometimes you need to do lspci calls to figure out which one to activate…)

Or of course it could be your card is fried. :-( But don’t give up yet.

Thank for the prompt reply.

My suspicious is this is the second time, the first one with the GTX480 I was talking in the previous thread. In both cases first time with just one card Ubuntu booted no problem, I run my code the screen goes blank (with the GTX480 it went first to multicolor snow and then totally green in the space of like 5-6 seconds). At second reboot the motherboard is beeping (one long beep, 3 short ones) to indicate no vga detected.

When it happened with the GTX480 I thought it was some drivers/installation problems, or I was not following the right steps. But now it happened twice with different cards on same configuration. Now I’m running on a GTX285 for Mac (the new drivers 195.36.24 actually recognize the card in Ubuntu) and I definitively don’t have spare cards to test it.