Known Issues with Clara Holoscan SDK v0.2 release

With the Clara Holoscan SDK v0.2 release, there are a few known issues

  • [3655489] Installing dGPU drivers can remove script from the executable
    search path. Explicitly including /opt/nvidia/l4t-gputools/bin in the PATH
    environment variable ensures this script can be found for execution.

  • [3599303] Linux kernel is not built with security hardening flags. Future releases will
    include a Linux kernel built with security hardening flags.

  • [3633688] RDMA on the Clara Holoscan Developer Kit is not functional. This will be fixed
    in future PCIe switch firmware updates. RDMA for the Clara AGX
    Development Kit is functional and unaffected by this issue.

  • [3671100] Configuring the PCIe BAR size on the Clara Holoscan Devkit to 8GB can
    cause the NVIDIA device driver to fail to load. Setting to the default BAR size
    of 256MB allows the device drivers to load. Future software updates may
    enable larger BAR sizes.

  • [3675821] The largest resolution of HDMI-CSI input is restricted to 2K in iGPU mode and
    new UEFI firmware does not autodetect the HDMI-CSI converter. 4K may be
    supported in future software updates, and manual detection of the converter
    can be forced by executing the /opt/nvidia/jetson-io/ tool to
    configure the CSI Connector / HDMI CSI input.

  • [3690268] The 10GbE ethernet port on the Clara AGX Developer Kit is not enabled due
    to firmware issue, with fix pending.

I got an issue when running ./apps/endoscopy_tool_tracking/run_tracking_replayer

[65543] GLX: Failed to create context: GLXBadFBConfig │···········
2022-06-30 12:35:52.479 ERROR gxf_extensions/visualizer_tool_tracking/visualizer.cpp@189: Failed to create GLFW window │···········
2022-06-30 12:35:52.517 WARN gxf/std/greedy_scheduler.cpp@221: Error while executing entity 38 named ‘visualizer’: GXF_FAILURE │···········
2022-06-30 12:35:52.535 INFO gxf/std/greedy_scheduler.cpp@353: Scheduler finished. │···········
2022-06-30 12:35:52.535 ERROR gxf/std/program.cpp@373: wait failed. Deactivating… │···········
|==================================================================================================================================================================| │···········
| Job Statistics Report (regular) | │···········
|==================================================================================================================================================================| │···········
| Name | Count | Time (Median - 90% - Max) [ms] | Load (%) | Exec(ms) | Variation (Median - 90% - Max) [ns] | │···········
|------------------------------------------------------------------------------------------------------------------------------------------------------------------| │···········
|==================================================================================================================================================================| │···········
2022-06-30 12:35:52.538 ERROR gxf/core/runtime.cpp@1173: Graph wait failed with error: GXF_FAILURE │···········
2022-06-30 12:35:52.539 ERROR gxf/gxe/gxe.cpp@316: GxfGraphWait Error: GXF_FAILURE

Any suggestions please, thanks in advance,


Hello, perhaps this troubleshooting suggestion could be of help?

Unfortunately not, The GLFW is initialized but not created.
"passing * -u $(id -u):$(id -g) to docker run, or running xhost +local:docker on your host ", do not work for me
I tested also the this container from Clara Holoscan Sample Applications | NVIDIA NGC, an dI got the same error.


I had to add -e XAUTHORITY in docker run,
docker run --runtime=nvidia --rm -it -v /media/m2:/m2 -v /tmp/.X11-unix:/tmp/.X11-unix -e DISPLAY -e XAUTHORITY -e NVIDIA_DRIVER_CAPABILITIES=all

it works now