Kodak SD Card cannot be used on Xavier

I bought a Kodak 128G Micro SDXC card and inserted it into Xavier, but I cannot see it in /dev
I expect mmcblk1 in lsblk output, but failed.

nvidia@jetson-0423718018003:~$ lsblk
loop0 7:0 0 16M 1 loop
mmcblk0 179:0 0 29.1G 0 disk
├─mmcblk0p1 179:1 0 28G 0 part /
├─mmcblk0p2 179:2 0 500K 0 part
├─mmcblk0p3 179:3 0 500K 0 part
├─mmcblk0p4 179:4 0 4M 0 part
├─mmcblk0p5 179:5 0 4M 0 part
├─mmcblk0p6 179:6 0 512K 0 part
├─mmcblk0p7 179:7 0 512K 0 part
├─mmcblk0p8 179:8 0 384K 0 part
├─mmcblk0p9 179:9 0 384K 0 part
├─mmcblk0p10 179:10 0 2M 0 part
├─mmcblk0p11 179:11 0 2M 0 part
├─mmcblk0p12 179:12 0 128K 0 part
├─mmcblk0p13 179:13 0 1M 0 part
├─mmcblk0p14 179:14 0 1M 0 part
├─mmcblk0p15 179:15 0 1M 0 part
├─mmcblk0p16 179:16 0 1M 0 part
├─mmcblk0p17 179:17 0 256K 0 part
├─mmcblk0p18 179:18 0 256K 0 part
├─mmcblk0p19 179:19 0 512K 0 part
├─mmcblk0p20 179:20 0 512K 0 part
├─mmcblk0p21 179:21 0 4M 0 part
├─mmcblk0p22 179:22 0 4M 0 part
├─mmcblk0p23 179:23 0 512K 0 part
├─mmcblk0p24 179:24 0 512K 0 part
├─mmcblk0p25 179:25 0 6M 0 part
├─mmcblk0p26 179:26 0 6M 0 part
├─mmcblk0p27 179:27 0 128M 0 part
├─mmcblk0p28 179:28 0 128M 0 part
├─mmcblk0p29 179:29 0 64M 0 part
├─mmcblk0p30 179:30 0 64M 0 part
├─mmcblk0p31 179:31 0 512K 0 part
├─mmcblk0p32 259:0 0 512K 0 part
├─mmcblk0p33 259:1 0 1M 0 part
├─mmcblk0p34 259:2 0 8M 0 part
├─mmcblk0p35 259:3 0 8M 0 part
└─mmcblk0p36 259:4 0 708.6M 0 part
mmcblk0boot0 179:32 0 8M 1 disk
mmcblk0boot1 179:64 0 8M 1 disk
mmcblk0rpmb 179:96 0 4M 0 disk

It should be mmcblk1. You might run “dmesg --follow”, and then see what shows up upon SD card insert (then post that information here).

Hello, I got the same problem here. I inserted a micro SD card and could not access to it.
When I run this command above: lsblk, or tried to find it with “fdisk -l”, I didnot to find the newly inserted sd card. Pls help.

Those should show the SD card if the signal quality is sufficient to see it. This leads me to believe it is either a hardware failure (possibly at the SD card end…you should try different brands and see if it is the same issue), or else a device tree setup issue.

For the case of device tree, are you using the development kit carrier board, or is it a custom carrier? Default flash should work for the development kit, but a device tree change would be required for custom carriers. An invalid device tree would cause the SD card slot to not be found.

Which software release are you using, and has the SD card worked previously?

Hello, I am using the Jetson Xavier Developer Kit. I used JetPack4.3 to flash with cuda10, trt6, etc. The SD card works quite well on my mobile phone. I know someone also met the same problem with SD card, but it worked for him after plug-in/plug-out many times.

Using the dev kit “lsblk” should indeed show the card, and inserting or removing should show logging in “dmesg --follow”.

My thought is that perhaps the SDXC is not supported, but so far as I know this would simply revert to a lower speed if not supported (I could be wrong on that). Would anyone from NVIDIA be able to confirm if SDXC is supported, and if not, whether speed would revert to something else and still show up in dmesg?

Many thanks for your kindly reply. I tried this sd card with a usb stick reader, it worked finally. So this solved my problem for now. It was indeed SDXC, microSD UHS-I storage card.