Kubuntu 18.04 (Ubuntu with KDE) GTX 1070ti screen becomes black and fans spin up

Hello,

after asking search engines and the nVidia support, I was directed here.
I am currently facing this issue:
After a few hours (even when just browsing) my screen becomes black, the fans spin to (probably) maximum, but everything else still works fine (for example sound, and I can still open a Terminal via shortcut and shut the system down with it). CPU integrated graphics work fine and I am currently using them. Temps seem to be fine (at least when I hold my hand against the cooler, it doesn’t hurt).
My hardware:
-Motherboard: ASUS Z-170-P
-CPU: i7-6700
-Graphics card: nVidia Geforce GTX 1070ti
Software:
-OS: Kubuntu 18.04
-nvidia-xconfig output:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 390.116  (buildmeister@swio-display-x64-rhel04-14)  Sun Jan 27 07:47:55 PST 2019


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Rebooting doesn’t really seem to help, but turning off and waiting does.

Thanks for time of reading this and for the help in advance.
If you want to say something about how I can improve posts like this, I would appreciate it.

Kuhluh
nvidia-bug-report.log.gz (1.13 MB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Ok, I have attached it to my first post.
Thanks for the fast answer.
Kuhluh

That looks like some HW failure, sometimes the 1070 isn’t even there right on boot, so it wasn’t properly initialized by the mainboard/bios. The bios is from 2015, start by checking for update for it, if that doesn’t help you can only check the parts one after another, PSU, 1070, mainboard.

OK, so I updated the UEFI.
Can I ask to look at the file (I run the script again) and tell me if something changed?
Thanks for the tips.

PS: seems like the file upload hangs at scanning, so could take some time, but it’s much smaller
nvidia-bug-report.log.gz (584 KB)

The last three boots were fine but I think you should test this for some days.

Yeah, I will test this further.
So I will probably write another post next weekend (probably Sunday evening/night (it is currently 10:30 pm for me)).
But so far, big tanks for the help.

OK, I tested it.
The problems was solved by updating my UEFI.
generix, big tanks for the help.