Kubuntu 22.04 freezes on boot after install driver 390 (GeForce GT 630M)

Hello everyone. I own an 11 year old laptop, model Samsung 550P (NP550P5C). A few months ago, I installed Kubuntu 22.04 and it’s been good, however whenever I try its proprietary driver (nvidia-driver-390), it freezes on boot.

I can make the GPU work temporarily by disabling sddm (KDE’s Simple Desktop Display Manager), making some modifications and enabling sddm which I got from the AskUbuntu website, commands bellow:

sudo systemctl stop sddm - to stop KDE’s sddm
sudo rmmod nouveau - to remove nouveau modules
sudo apt install -y nvidia-driver-390 - to install the nvidia drivers
sudo modprobe nvidia_drm nvidia_modeset nvidia - to load nvidia modules
sudo systemctl start sddm - to start KDE’s sddm

However, when rebooting or powering on, the system always freezes on boot.
Can anyone help me?

I am attaching the bug report
Processing: nvidia-bug-report.log.gz…

The upload didn’t work. Please try unzipping it.

And now?
nvidia-bug-report.log (1.3 MB)

Please enable log persistence for systemd-journald, reboot with the driver installed and create a new nvidia-bug-report.log.

I did as you instructed and I hope I did it properly. If I didn’t, I apologize.
Using the method to make the GPU work temporally, I made the nvidia-bug-report.log (see attachment with a date and time). Then I rebooted my system, but it still freezes therefore I was unable to generate the bug report after reboot.

2022-12-09-19-42_nvidia-bug-report.log (1.3 MB)

Log persistence is still disabled.

Hello, my apologies for my ignorance, but I made the mistake of enabling persistent storage for the systemd journal log.
I realize my mistake. Line 9084 shows persistence mode ENABLE. Did I do it properly?

2022-12-12 -17-58_nvidia-bug-report.log (1.3 MB)

Your first idea was the correct one, like this:
If you did so, it didn’t work for some unknown reason, please check.
journalctl -b-1
give you any output?

Yes, it did, see this attachment:
journalctl -b-1_output (6.8 KB)

And so you know, I altered line 18 in the /etc/systemd/journald.conf file to #Storage=persistent