L4T 21.5 on Jetson TK1

Hi all,

I recently got a TK1 DevKit, and while it worked fine out of the box, I tried re-flasing it with L4T 21.5, really just as an exercise to get familiar with it.

The command
‘sudo ./flash.sh jetson-tk1 mmcblk0p1’ seemed to work fine, took about 29 secs and said everything was successful, but when the board tried to re-start, it hangs at
[36.779743]—[end trace 5c0486ac576fac80]—

I’m afraid I’m quite new to all this, so really have no idea what’s going on and am quite stuck. Can someone help me please, preferably with advice that is geared towards a complete novice??

Thank very much.

hello akkurrab,

could you please attach full kernel message till the crash.
thanks

Hi akkurrab,

Please following below steps to flash image:
sudo tar xpf Tegra124_Linux_R21.5.0_armhf.tbz2 cd Linux_for_Tegra/rootfs/
sudo tar xpf ../../Tegra_Linux_Sample-Root-Filesystem_R21.5.0_armhf.tbz2 cd …
$ sudo ./apply_binaries.sh

OR you can try to install via JetPack3.0.
https://developer.nvidia.com/embedded/dlc/jetpack-l4t-3_0

Hi guys

Thanks for your replies.

First of all I’m not sure how to copy the full kernel message from the TK1 onto the host? I’ve read somewhere that there is a debugging capability via the serial DB9 connector to the host? Are you able to let me know how I could do this please?

Anyway I tried the installation via JetPack3.0 and it seems to work fine, Ubuntu displays correctly on the TK1. I couldn’t complete the installation though as I had a few issues with my internet tonight. I will give it another go tomorrow and let you know if it works ok.

Thanks very much.

The easy way to copy the kernel message is by serial console if you have that. The 9-Pin D-Sub connector uses settings 115200 8N1 (I use CTS/RTS flow control, though software/no flow control works). The serial console programs (such as minicom or gtkterm) have logging options.