L4T35.3.1, Delete boot options and change boot orders do not work

We added a PCIe network adapter and Xavier NX started to boot very slowly by waiting for IPv6, IPv4, … boots before boot to EMMC.
I hit “ESC” during boot, detected all other boot options except EMMC boot from “Boot maintenance manager”, hit F10 and “Y” to save the settings. The changes get lost after reboot.
I tried to change boot order instead. The changes also got lost after reboot.
This did not happen for L4T32.
How can this be fixed?
Thanks in advance.


will it still happen if you detach the PCIe network adapter?
Given that you mention Xavier NX and PCIe in the same sentence, you are using a custom board, right? Also, what PCIe network adapter is in use?

The HTTP boots only happen when RTL8125 adapter is attached. We used M.2 to PCIeX1 adapter for the RTL8125 adapter on Xavier NX Dev Kit.
Amazon.com: 2.5GBase-T PCIe Network Adapter RTL8125B 2500/1000/100Mbps PCI Express Gigabit Ethernet Card RJ45 LAN Controller Support PXE for Windows/Linux/MAC with Low Profile : Electronics
The issue is the boot order could not be saved for L4T35.3.1.
EMMC should be the first boot for most users.


there is some issue with deleting boot options, and we have tested that changing boot order should work.

I tried that. When the adapter is detached and attached again, the saved boot order went back to default HTTP boot.

That sounds weird. We’ll see if we can reproduce it on our side.
Did you also hit this issue with other PCIe devices?

It does not happen when VNME SSDs are used.
Is it possible to rebuilt boot loader to delete all other options?


is there a bootable system on your NVMe SSD?
We just tested with systems installed on both eMMC and NVMe SSD, and we can successfully switch between these two.

Did you mean that with the NVMe SSD removed, even if you detach and attach the PCIe network adapter, the boot order would still be preserved after reboot?

The NVME SSD is only for data. L4T35.3.1 was installed on EMMC only.
When NVME SSD is attached without RTL8125 adapter, L4T35.3.1 boots correctly.
When RTL8125 adapter is attached without NVME SSD , L4T35.3.1 boots very slowly with HTTP boots and the boot order can not be preserved.


may I ask what M.2 to PCIe adapter you are using? We’ll see if we can re-produce this issue if we can have the same hardware setup.
Did you also hit this issue with other PCIe network card or other M.2 to PCIe adapter?

The following M.2 to PCIe adapters were used:

We only tested RTL8125 based PCIe to 2.5GigE adapters,
We also have custom Xavier NX carriers and custom PCIeX1 to 2.5GigE adapters using RTL8125 without using M.2 to PCIE adapter.
Rather than finding the same hardware to test, will it be easier for you to provide instructions to modify boot loader to remove all boot options other than EMMC boot?


Does it work fine with this hardware setup?
We’ll see if we can re-produce this issue on our side with the adapter.

The issue is that currently our UEFI, with quick boot disabled, scans for new hardware changes upon boot, and add these options to the top of the order, so deleting boot options may not be an option when you have some external devices attached.

Boot order could not be saved for commercial or custom RTL8125 based PCIe to 2.5G adapter.
How can I enable quick boot?

I’m not sure if it’s something meant to be changed by users.
We’ll keep you updated and please wait.

And the link seems invalid. It goes to a Page Not Found. Could you check and share a valid link?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.