Lack of USB3.0

DaneLLL, hi,

I shall remove all OCs from the device tree.

Though on the second part I got confused. I’ll try to put what I understand in my words: the VBUS controller is an external device to the Jetson module which provides only power to external USB3.0 devices. The A18 is a pin which is connected to the VBUS controller and enables it. How a reset to this controller affects the Jetson with USB3.0 devices enumeration?

This is a sequence of initialization as I understand it:

  1. The xhci initialized.
  2. 5[V] is supplied via the VBUS - to no devices
  3. The USB3.0 lanes are open nothing is attached
  4. Over Current is identified as a result of some unknown reason, BTW we see no Over Current message on the terminal - in the past when we connected a malfunction USB2.0 device we saw this message and as a result all USB were disabled. This is not what we witness today.
  5. xhci controller is disabled.

What do you mean applying HW reset, do you mean the VBUS?
Regards.

Yes, as the other user has tried in
https://devtalk.nvidia.com/default/topic/1036547/jetson-tx1/usb2-b43-b42-not-working-on-tx1-with-r28-2/post/5265898/#5265898

The VBUS of USB3 port is connected to A18. You can disable the GPIO for a few second after booting, and then re-enable it. Check if it triggers enumeration.
Or remove connection with A18 and connect VBUS to power supply directly. After booting to kernel, turn off the power supply for a few second and turn on.

We have suggested the same to some users and they were willing to give it a try. Hope you can also try it out.

DaneLLL, hi,

I have tried to follow the following terminal to enable and disable A18:

sudo su
cd /sys/class/gpio
echo 413 > export
cd gpio413
echo out > direction && echo 0 > value # Will turn off the port
echo out > direction && echo 1 > value # Will turn on the port

but failed:

echo 413 > export
bash: echo: write error: Device or resource busy

Any suggestions?

Something else is already using it. What do you see from:

egrep 413 /sys/kernel/debug/gpio

Hi linuxdev,

hereafter the output per your suggestion:

<b>sudo su</b>
<b>cd /sys/class/gpio</b>
<b>echo 413 > export</b>
bash: echo: write error: Device or resource busy
<b>egrep 413 /sys/kernel/debug/gpio</b>
 gpio-413 (                    |vdd-usb1-5v         ) out lo

any suggestions?

There you go…that GPIO is already being used as another function. You probably don’t want to remove USB 5V, so probably pick a different GPIO pin. Was there a reason you chose 413?

It’s define as regulator, try below command to enable it.

sudo su
echo enable > /sys/kernel/debug/regulator/vdd-usb1-5v/regulator/state

Please also remove the functionality as an oc-pin.

nvidia,oc-pin = <1>;