Lagging in ue5.2 when connector plugin is active

In UE5.2 with connector version: 201.1.158 Every time when I try to move rotate or scale a static mesh, my computer’s vents go loud and the operations go lagging. Yesterday it was fine so it’s not my pc config. Can anyone help me please?
Only does it with static meshes, skeletal mesh is fine. I tried to delete intermediate and save folders, still not working.
Please let me know if you need further details!
I turned omniverse plugin off and all get back to normal. Turned back on, and now lagging again.

Not sure if this is practical for you but since running UE5 and Composer side by side creates a scenario where both systems are pulling resources from the same gpu, I was thinking about having a second pc in a side by side setup, one for each program.

It may not be set by default and I can’t recall the name of it, but I think there is a setting in Unreal where it will go into sort of a background mode if its minimized or if you jump over to another program, so its still on and running but not pulling maximum possible resources. This can be toggled if this has anything to do with your scenario.

@muszti86, in 202.0 we made a change to “Improve the perf of moving a transform and changing the hierarchy in a large stage”. I would encourage you to try the latest Connector version (now 202.1) and see if there’s any improvement.

Oh, now that I see the version you listed, 201.1.158, you probably mistyped and meant to type 202.1.158, which is indeed the latest version.

When you say that you “move rotate or scale a static mesh and things slow down”, is this just in any plain Unreal level, or specifically in a USD stage that you’ve opened?

Dear Lou Rohan!
Now I can use it just fine.

It was a mistake made by myself.
I was using a scene from my nucleus, then uninstalled the nucleus server and reinstalled it to another SSD drive. Ue5 had my omniverse connector actor in the hierarchy. With empty version of the models came out of usdz.
I deleted those empty game objects. And started to import usds as a model, not as a scene.
All is good now. Thanks for trying to help!

LouRohan via NVIDIA Developer Forums <> ezt írta (időpont: 2023. júl. 25., K 23:48):