Laptop boot delayed by Error: [drm:lspcon_init [i915]] *ERROR* Failed to probe lspcon

My Precision 7550 with Quadro RTX 3000 running Ubuntu takes about 40 seconds to boot, half of which is spent looping the following error:

[   30.115460] [drm:lspcon_init [i915]] *ERROR* Failed to probe lspcon

[   30.115538] [drm:lspcon_resume [i915]] *ERROR* LSPCON init failed on port D

This error also pops up when opening certain applications such as gnome-control-center or steam, which will freeze the computer for a few seconds, then show the following error:


[   67.741827] [drm:lspcon_init [i915]] *ERROR* Failed to probe lspcon

[   67.741907] [drm:lspcon_resume [i915]] *ERROR* LSPCON init failed on port D

[   68.396337] [drm:lspcon_init [i915]] *ERROR* Failed to probe lspcon

[   68.396412] [drm:lspcon_resume [i915]] *ERROR* LSPCON init failed on port D

[   70.853888] usb usb3: root hub lost power or was reset

[   70.853892] usb usb4: root hub lost power or was reset

I’ve attached two full outputs of sudo dmesg -w (dmesg-log-1 (96.1 KB), dmesg-log-2 (97.6 KB)
), the latter one throwing in some fun Failed to grab modeset ownership errors too.

In the first log, from time 0 to 38 is the boot sequence (with massive delays from 7 to 15 and 18 to 36 seconds), from time 67 to 70 is trying to open gnome-control-center.

I’ve tried running Ubuntu 20.04 and 21.10, usinsg lightdm and gdm3, and used NVIDIA driver versions 510 (recommended driver), 465, and Nouveau; the Nouveau driver managed to take off about 10 seconds worth of these errors, which better, but still abysmal. I’ve tried booting with no HDMI connected and with one, and get the errors in both cases.

Edit: I tried using a newer Linux kernel (5.15 stable instead of 5.13 stable), which reduced the number of errors and boot time, but also disabled the NVIDIA graphics card entirely. I also unchecked Enable Switchable Graphics in the boot menu, and the LSPCON errors disappeared almost entirely (of course, this also disabled the graphics card entirely).

The errors are from the intel igpu, nothing the nvidia driver can fix.
Please try upgrading to latest kernel using the liquorix ppa.
Furthermore, many hard ACPI errors are reported so you should look into updating your bios.

I actually updated the BIOS ealier, so it’s running the latest version, unfortunately. Will try the liquorix ppa.

The Liquorix kernel had a similar effect to upgrading to 5.15 (reduced errors) while keeping the GPU working, but introduced some weird lag issues. I’ll repost this to a more relevant forum.