Laptop only recognizes 1 screen (external or internal screen) not both at the same time


I run into a very strange bug, I have a gsx 2070 super mobile video card but after installing the latest drivers, the laptop only recognizes 1 screen at a time.

A restart is required for the laptop screen to work again, however the external screen does not work more than. When I restart with my external screen plugged in, my laptop screen does not work again.

Hopefully someone can help me because this makes me a bit desperate.nvidia-bug-report.log (1.8 MB)

Hi Willem,

From your bug report log, it looks like your laptop uses a hybrid graphics configuration, where the internal panel is connected to an Intel integrated GPU and the external screen is connected to the NVIDIA discrete GPU.

In order to use both displays simultaneously, you’ll need to use a configuration that uses both GPUs simultaneously. There are two options there:

  • dGPU primary - the desktop is rendered on the NVIDIA GPU and displayed on the external panel directly, frames are sent to the Intel GPU for display on the internal panel. This mode is often referred to as “PRIME”.
  • iGPU primary - the desktop is rendered on the Intel GPU and displayed on the internal panel directly. Frames are sent to the NVIDIA GPU for display on the external panel. This mode is often referred to as “Reverse PRIME”. In this mode, you can choose to run specific graphics-heavy applications on the NVIDIA GPU.

Looking at your system configuration, it looks like there’s a configuration file that would set your system up in a dGPU-primary configuration: /etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf (note the “PrimaryGPU” option that overrides the default Intel primary GPU).

However, you have a configuration file in /etc/X11/xorg.conf that overrides this automatic configuration and specifies a configuration that only uses the NVIDIA GPU. This is likely why your internal panel isn’t working.

Given your system setup, I would recommend using an iGPU-primary “render offload” configuration, which you should be able to do by deleting both /etc/X11/xorg.conf and /etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf and instead letting the system autoconfigure itself.

You might also want to look into enabling the runtime power management options documented in Chapter 22 of the README. Combined with render offload, this will allow the NVIDIA GPU to be powered off when no applications are running on it and the external display is disabled.

Thank you for your fast response, but i dont get what to do now

Move /etc/X11/xorg.conf and /etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf to a backup location and then restart your display manager (or just reboot the whole computer).

Ah i have done this before, but my laptop doesn’t recognize my second screen then anymore.

nvidia-bug-report.log (1.8 MB)

nvidia-settings doesn’t know how to configure displays in this mode.

Normally the desktop environment takes care of binding GPUs together for display offload, but maybe yours doesn’t for some reason. Can you please check the output of xrandr --listproviders and also try running xrandr --setprovideroutputsource 1 0; xrandr --auto ?

Providers: number : 2
Provider 0: id: 0x43 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 1 associated providers: 0 name:modesetting
Provider 1: id: 0x1ee cap: 0x2, Sink Output crtcs: 4 outputs: 6 associated providers: 0 name:NVIDIA-G0

BUTTTT xrandr --setprovideroutputsource 1 0; xrandr --auto DID THE TRICK
thank you very much i am very very gratefull !!

1 Like

Excellent, glad to hear it’s working!

Are those settings automatically saved or do i need to nvidia-xconfig ?

Unfortunately these commands have to be run after the X server starts. Typically your desktop environment would take care of this but if yours doesn’t, you’ll have to check how to add these commands to the startup scripts for your desktop.

1 Like

I will make a sh for it :)


A update i buy a new screen but this screen is doing very weird !!

This is my output screen on high resolution.

i tried several thing to fix it but cant find how to fix it.

We’ve identified the cause of this problem and a fix should be available in a future release.

is there for now there is now fix ??? or a beta version ?

??? is there any fix for it ;(