Laptop Wakes Up from suspend, But no Display Output [ More info in desc.]

Has anyone experienced this issue? And how have you resolved it?

I have a Lenovo Legion 5i 2022, with an i5 12500H and an NVIDIA RTX 3060 Mobile with the proprietary NVIDIA Driver version 520.56.06 installed through the


package. I also must specify that I am dual-booting with windows 11, secure boot enabled and I followed a guide to signing the NVIDIA kernel module to make it work with secure boot enabled.

With Fedora 37 installed and booted with Hybrid Graphics Mode enabled in the BIOS, Once the laptop is suspended by closing the lid, the laptop display does not show any output. Its just a black screen.

TO BE CLEAR, the laptop WAKES UP from sleep just fine. The laptop shows the slow blinking light when its in sleep and the light turns static white when its awake , the keyboard backlight also turns on. But the DISPLAY has no output.

What finally worked for me was to boot the OS in “Discrete Graphics Only” Mode in the BIOS. But obviously I can’t keep it that way as this will kill my battery life and is highly inefficient.

I used this This Bug Filing for an answer, but Its an old post and that specific case was solved with an update.

I think it is also worth mentioning that I’m Using Wayland as it’s the default on Gnome Fedora. I posted the issue in r/Fedora and r/LinuxHardware, but I was told to post here.

Known bios bug of that lenovo legion model affecting the intel gpu:
Please check for a bios update, maybe this has been fixed meanwhile.