Large display offset on monitor after X server starts (Kubuntu, nvidia 104.121, dell2001fp)

GeForce 7800 GTX on Kubuntu 12.04.
Monitor is DELL2001FP over VGA (DVI to VGA adapter)

The display is perfectly aligned during boot (bios display, kubuntu 12.04 screen with moving dots…), however as soon as X starts up, the display is offset about 1/3 to the right and just enough down not to see the bottom bar. (both the login screen and KDE itself are off). This is not something that I can adjust with the monitor settings, not enough range.

This used to work fine some time ago (guessing about a year ago?), and I’m pretty sure it started after a system update. Unfortunately I had to deal with a sudden medical condition that took me off my feet for 6 months right around that time, so I never addressed the problem then. Part of why it wasn’t a priority (in addition to my medical problems) was that I mostly used that system remotely over VNC (which doesn’t show an offset).
I think I remember (but I could be wrong), that the problem started with a system update that updated the kernel, which left me with non-working drivers. Usually updating kernel modules works flawlessly, but I think I remember X wouldn’t start at all, I spent several hours trying a number of things off the internet, and finally got it in the state it is in right now. I have tried to fix it a couple of times since then, so I have lost track of all the gyrations I went through, with no success.
the last think I attempted a few days ago was to update the driver to 104.121 from whatever it was before (104.136?) but it didn’t fix the problem.

I now need to use the actual monitor more often than using VNC, so I’d like to get it fixed but I am out of ideas.

when I tried to start X with -logverbose 6 it didn’t start, so I only ran nvidia-bug-report.sh with the “normal” X logging. I also can’t figure out how to attach it to my post, do I need to host it somewhere and provide a link?

here’s the install log, although it doesn’t seem to show much of interest:

nvidia-installer log file ‘/var/log/nvidia-installer.log’
creation time: Thu Apr 24 21:40:05 2014
installer version: 304.121

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

nvidia-installer command line:
./nvidia-installer

Using: nvidia-installer ncurses user interface
-> License accepted.
-> Installing NVIDIA driver version 304.121.
-> Running distribution scripts
   executing: '/usr/lib/nvidia/pre-install'...
-> done.
-> The distribution-provided pre-install script failed!  Continue installation anyway? (Answer: Yes)
-> Would you like to register the kernel module sources with DKMS? This will allow DKMS to automatically build a new module, if you install a different kernel later. (Answer: Yes)
-> Installing both new and classic TLS OpenGL libraries.
-> Installing both new and classic TLS 32bit OpenGL libraries.
-> Install NVIDIA's 32-bit compatibility OpenGL libraries? (Answer: Yes)
-> Searching for conflicting X files:
-> done.
-> Searching for conflicting OpenGL files:
-> done.
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86_64' (304.121):
   executing: '/sbin/ldconfig'...
   executing: '/sbin/depmod -aq'...
-> done.
-> Driver file installation is complete.
-> Installing DKMS kernel module:
-> done.
-> Running post-install sanity check:
-> done.
-> Post-install sanity check passed.
-> Shared memory test passed.
-> Running runtime sanity check:
-> done.
-> Runtime sanity check passed.
-> Would you like to run the nvidia-xconfig utility to automatically update your X configuration file so that the NVIDIA X driver will be used when you restart X?  Any pre-existing X configuration file will be backed up. (Answer: Yes)
-> Your X configuration file has been successfully updated.  Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86_64 (version: 304.121) is now complete.

Let me know if I can provide any other info. I need to figure out how to upload the bug report.

nvidia-bug-report.log.gz (48.3 KB)

OK, once I posted there was a paperclip at the top of my post, so I think I now attached the bug report.

here’s my /etc/X11/xorg.conf if it helps:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.121  (buildmeister@swio-display-x86-rhel47-06)  Tue Mar  4 20:56:42 PST 2014

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 331.20  (buildd@allspice)  Wed Dec 18 09:07:35 UTC 2013

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"                                                   
    Option         "Protocol" "auto"                                         
    Option         "Device" "/dev/psaux"                                     
    Option         "Emulate3Buttons" "no"                                    
    Option         "ZAxisMapping" "4 5"                                      
EndSection                                                                   
                                                                             
Section "InputDevice"                                                        
                                                                             
    # generated from default                                                 
    Identifier     "Keyboard0"                                               
    Driver         "kbd"                                                     
EndSection                                                                   
                                                                             
Section "Monitor"                                                            
    Identifier     "Monitor0"                                                
    VendorName     "Unknown"                                                 
    ModelName      "DELL 2001FP"                                             
    HorizSync       31.0 - 80.0                                              
    VertRefresh     56.0 - 76.0                                              
    Option         "DPMS"                                                    
EndSection                                                                   
                                                                             
Section "Device"                                                             
    Identifier     "Device0"                                                 
    Driver         "nvidia"                                                  
    VendorName     "NVIDIA Corporation"                                      
    BoardName      "GeForce 7800 GTX"                                        
EndSection                                                                   
                                                                             
Section "Screen"                                                             
    Identifier     "Screen0"                                                 
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1600x1200"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Any idea where else I can get help on this issue? I thought this was where the NVIDIA web site sent me for linux support.