LaserScan not visualized in rviz

Hi, I am trying to visualize the laser scan in rviz from example Communicating > ROS > Navigation and have this error. Did I do anything wrong or is it a bug?

Can someone please test it and confirm?

Bug will be fixed in our next release.The easiest way to workaround this is to:

*Set lidar rotation rate to zero in isaac-sim, this will publish a full scan each frame.
*republish the time_increment parameter using this script (1.1 KB)

1 Like

Thanks for you reply, currently I am using ROS, not ROS2. Does your solution work with ROS?

This should work for ROS as well. Please try it out and let us know if you still have any issue.

I see what you did there, you just set the time_increment to 0.0 and publish it again. I couldn’t run the script because I didn’t install ROS2 and I don’t plan to use it. However I ran another script in ROS with the same idea as yours. And it worked. (699 Bytes)

great it hear you got it working and thanks for sharing the code :)

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.