Launch timed out

Hi all

I’ve been reading about the “launch timed out and was terminated” problem in this forum. It seems that the watchdog timer is the guilty. I read the solution under Windows but anyone knows the solution on a Linux machine? Is there any option in the nvcc which disable the “launch time out” of the kernels? Really the only solution is to add a new graphic card in my computer? Can I configure my card in mode “compute only” if I only have 1 GPU in my computer? (I know it sounds stupid but maybe It can be done during the kernel execution)

Thank you every one

On linux, you can shutdown the display manager and run from the console without any interference from the watchdog timer.

The problem is that my application is an openGL application and I can’t shutdown the display manager. Is there some way to change the parameter of the watchdog timer time?

No. The only options open to you are to more finely divide your kernel work load, and call it more frequently, so that the execution time per kernel call is less, or make your code run faster, or use a dedicated compute card for the CUDA kernel. Take your pick.

My best option is to run my code faster :) But believe me, I tried everything to make it max efficient.

For the moment I will divide my kernel into several steps and later I will seriously think on get another card just for computing.

Thank very much for your reply.