Launcher unable to download GDPR agreements


I am trying to install Omniverse, and as soon I start the launcher and log in in to the account it gives the massege:

“unable to download GDPR agreements and EULA. You may need to inspect your internet connection and restart the launcher”

I have tried to run a launcher (as an administrator) on 2 diffirent laptops, and with to diffierent internet connections, with firewall both on and off, but the issue remains.

What should I do?

CPU: 11th Gen Intel(R) Core™ i9-11950H @ 2.60GHz 2.61 GHz
GPU: NVidia RTX A5000 for laptops

Hello @antonradzevitch! Unfortunately this issue is with Amazon AWS in relation to recent US export laws and sanctions programs which prevents services in affected regions. This could mean that a part of your region communication is going through blocked servers.

Will NVidia do something about it? Or is it Ok for NVidia?


I had the same problem. Fixed it by changing time-zone of my computer from (GMT+5:30) to (GMT-12). Then RESTARTED my computer. Launched the Omniverse Launcher and it worked!

After installing Cache and Nucleus, I changed time-zone to the correct one. Restarted my computer again and it works smoothly.