Lenovo T61P with Quadro 570M problems

I have a Lenovo Quadro T61P with an Nvidia quadro 570M GPU. From Lenovo the latest driver is Forceware 177.15.

I have tried Cuda v2.1 and Cuda v2.0, both with mixed results. Simple applications work,
eg deviceQuery.exe gives -
There is 1 device supporting CUDA

Device 0: “Quadro FX 570M”
Major revision number: 1
Minor revision number: 1
Total amount of global memory: 268107776 bytes
Number of multiprocessors: 16
Number of cores: 128
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 16384 bytes
Total number of registers available per block: 8192
Warp size: 32
Maximum number of threads per block: 512
Maximum sizes of each dimension of a block: 512 x 512 x 64
Maximum sizes of each dimension of a grid: 65535 x 65535 x 1
Maximum memory pitch: 262144 bytes
Texture alignment: 256 bytes
Clock rate: 0.95 GHz
Concurrent copy and execution: Yes


and simple examples work however most of the supplied projects do not work. For example bitonic.exe gives an error -

cutilCheckMsg() CUTIL CUDA error: Kernel execution failed … line 79 invalid device function

line 79 is a simple value assignment so I don’t think that is it.

I see the version numbers for the supported drivers are not the same as the Lenovo driver, however I couldn’t get aything else to install.

Does anyone know if that is the problem ? and if so will version 1.0 work ? or is there something else I can try ?


install a newer driver; you’ll have to add lines to the 181.20 INF in order to get it to recognize your card. we’ve posted how to do this several times, so searching should let you find it (it’s not hard, takes about 5 minutes)

Thanks ! quick response ! I’ll give it a go.

Ok, I got it installed and all is working great !
I downloaded the driver 181.20 and the ran it noting where the driver files were stored,
then edited nv4_disp.inf to add the following lines -
in section
%NVIDIA_G84.DEV_040C.1% = nv4_WSApps_G8x, PCI\VEN_10DE&DEV_040C


; Localizable Strings
NVIDIA_G84.DEV_040C.1 = “NVIDIA Quadro FX 570M”

the re-ran setup and rebooted and it all worked fine with Cuda 2.1

I could not install the CUDA driver v2.2 for Lenovo T61p with Quadro 570M. It just says it cannot find the driver for the graphics hardware. I am using the driver: cudadriver_2.2_winxp_32_185.85_notebook.exe

Did anybody meet the same problem? How to solve this problem? Thank you,