Lenovo Z510 - Linux Mint 20.3 - unable to use NVIDIA drivers

Hi,

I can’t get any nvidia driver to run properly on my Lenovo z510. I tried all kinds of troubleshooting steps from this or ubuntu formus, no luck.

It’s a dual boot with Windows on a HDD, linux on an SSD.

I’m trying all this on 5.4.0-90 headers, but tried 5.4.0-26, also 5.8 (didn’t work at all), 5.11 (didn’t work at all) and 5.13 (same result).

System info: https://termbin.com/rij9
notice Nvidia "Lenovo driver: N/A "

The PC works ok, but having a bunch of Chrome windows open makes my sensors show 85-90 and fan is at full speed - it wasn’t like that a few months ago. I installed all Linux updates suggested by the Update Manager (which was probably a mistake, my PC is from 2014 and probably newer kernels don’t work for it as well. then I started troubleshooting and probably messed more things up…).

My sudo lspci -vnnn result:

07:00.0 3D controller [0302]: NVIDIA Corporation GK208M [GeForce GT 740M] [10de:1292] (rev a1)
Subsystem: Lenovo GK208M [GeForce GT 740M] [17aa:380a]
Flags: bus master, fast devsel, latency 0
Memory at b3000000 (32-bit, non-prefetchable) [size=16M]
Memory at a0000000 (64-bit, prefetchable) [size=256M]
Memory at b0000000 (64-bit, prefetchable) [size=32M]
I/O ports at 4000 [disabled] [size=128]
Expansion ROM at [disabled]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [100] Virtual Channel
Capabilities: [128] Power Budgeting <?>
Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
Capabilities: [900] Secondary PCI Express
Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

Note that line
Kernel driver in use:
is missing.

My nvidia-smi outputs

NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

as per NVIDIA driver 470 does not load correctly on Ubuntu 20.04
where I tried all the steps.

sudo ubuntu-drivers devices

output:
WARNING:root:_pkg_get_support nvidia-driver-390: package has invalid Support Legacyheader, cannot determine support level
== /sys/devices/pci0000:00/0000:00:01.1/0000:07:00.0 ==
modalias : pci:v000010DEd00001292sv000017AAsd0000380Abc03sc02i00
vendor : NVIDIA Corporation
model : GK208M [GeForce GT 740M]
driver : nvidia-driver-470-server - distro non-free
driver : nvidia-driver-450-server - distro non-free
driver : nvidia-driver-470 - distro non-free recommended
driver : nvidia-driver-390 - distro non-free
driver : nvidia-driver-418-server - distro non-free
driver : nvidia-340 - distro non-free
driver : xserver-xorg-video-nouveau - distro free builtin

I also tried:

sudo apt purge nvidia* libnvidia*
sudo apt install nvidia-driver-470
or again purge + 
sudo ubuntu-drivers autoinstall

vhen I run Driver Manager, I see this:https://i.imgur.com/aOPfTFP.png
Nvidia X Server Settings shows ok, with Performance Mode set up.

Xorg.conf has “nvidia” kernel in it.

So I actually don’t know whether my PC is using the Nvidia driver or not - different info in different places.

sudo lshw -c video

*-display UNCLAIMED
description: 3D controller
product: GK208M [GeForce GT 740M]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:07:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: latency=0
resources: memory:b3000000-b3ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:4000(size=128)
*-display
description: VGA compatible controller
product: 4th Gen Core Processor Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 06
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:31 memory:b5000000-b53fffff memory:c0000000-cfffffff ioport:6000(size=64) memory:c0000-dffff

Any insight will be much appreciated!

thanks!
Lukas

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Hi Generix,

here you go:
nvidia-bug-report.log (84.1 MB)

I had to boot using headers 5.4.0-58 as 5.4.0-90 now gets stuck on the splash screen.

BUT, when I entered recovery mode for -90 and ran nvidia-smi, it worked fine - see attached image.

thanks
Lukas

First of all, please delete /var/log/kern.log since this is flooded with errors

Mar 7 15:20:32 lukas-IdeaPad-Z510 kernel: [ 790.322295] NVRM: The NVIDIA probe routine was not called for 1 device(s).
Mar 7 15:20:32 lukas-IdeaPad-Z510 kernel: [ 790.322296] NVRM: This can occur when a driver such as:
Mar 7 15:20:32 lukas-IdeaPad-Z510 kernel: [ 790.322296] NVRM: nouveau, rivafb, nvidiafb or rivatv
Mar 7 15:20:32 lukas-IdeaPad-Z510 kernel: [ 790.322296] NVRM: was loaded and obtained ownership of the NVIDIA device(s).
Mar 7 15:20:32 lukas-IdeaPad-Z510 kernel: [ 790.322296] NVRM: Try unloading the conflicting kernel module (and/or
Mar 7 15:20:32 lukas-IdeaPad-Z510 kernel: [ 790.322296] NVRM: reconfigure your kernel without the conflicting
Mar 7 15:20:32 lukas-IdeaPad-Z510 kernel: [ 790.322296] NVRM: driver(s)), then try loading the NVIDIA kernel module
Mar 7 15:20:32 lukas-IdeaPad-Z510 kernel: [ 790.322296] NVRM: again.
Mar 7 15:20:32 lukas-IdeaPad-Z510 kernel: [ 790.322297] NVRM: No NVIDIA devices probed.

also set log persistence so the logs include data from earlier boots:
https://www.golinuxcloud.com/enable-persistent-logging-in-systemd-journald/

Then try recreating the initrd for kernel -90
sudo update-initramfs-c -k 5.4.0-90-generic
and delete /etc/X11/xorg.conf
then boot into that (Though the current ubuntu kernel should be -100?)
Please create a new nvidia-bug-report.log afterwards.

1 Like

all done, it helped! :)

I presume you meant sudo update-initramfs -c -k 5.4.0-90-generic (space after initramfs), output:
update-initramfs: Generating /boot/initrd.img-5.4.0-90-generic
I: The initramfs will attempt to resume from /dev/sda3
I: (UUID=9dc7d29f-9724-42b5-880d-ea804da71715)
I: Set the RESUME variable to override this.

Yeah, current kernel is -100, but when I updated to that, all this started happening, so I installed some older ones to be able to use my computer when the latest one broke. Now I’m using whichever works as I need it for work.

Seems that your steps fixed things :)

  1. I am able to boot into -90 now
  2. nvidia-smi works
  3. lspci -vnnn shows “Kernel driver in use: nvidia” (previously this line was missing)
  4. lshw -c video shows Nvidia as in use (no longer UNCLAIMED as above.
  5. Nvidia X Server Settings now shows many more options than before

Nvidia log looks different too:
nvidia-bug-report.log (2.6 MB)

Shall I try -100 kernel?

Thanks!
Lukas

Yes, there was a typo, space missing
Please first check
dkms status
if there’s also a driver for the -100 kernel available.
If yes, recreate the initrd like you did for the -90 kernel.

Though the nvidia gpu is running really hot, I guess the heat spreader is clogged with dust. Having nearly the same notebook, I have to clean it every two years.

only have these installed (I will be removing 5.13 when this is done)
nvidia, 470.103.01, 5.13.0-30-generic, x86_64: installed
nvidia, 470.103.01, 5.4.0-90-generic, x86_64: installed

But I don’t have -100 headers installed either. Should I try installing -100 headers, then sudo ubuntu-drivers autoinstall?

good point about the dust, I haven’t cleaned it in …erm… 3 years I guess!

No need to reinstall the drivers, installing the headers alone should trigger the compile so it should be visible in
dkms status

sorry, can’t respond on the website “access forbidden due to location”. I’m in Slovakia, have been when I started this topic, not sure if NVIDIA is clamping down on Russian hackers, but it needs to get its geography right.

dkms status - all seems to be working well:
nvidia, 470.103.01, 5.4.0-100-generic, x86_64: installed
nvidia, 470.103.01, 5.4.0-90-generic, x86_64: installed

Thanks Generix, you helped me a lot!
Lukas

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.