Leopard Imaging LI-AR0231-GMSL problems

We are having problems with our leopard imaging cameras and Drive PX2.

Our application runs successfully approximately 10 times but then dwSensorCamera_readFrame always returns DW_NOT_READY. This continues until we reboot the Drive PX2 and the application begins to work again.

We also have the equivalent Sekonix cameras with the same Onsemi AR0231 image sensors and we have never encountered the above problem.

Any ideas?

Hi Jamie,

Would you tell which PDK version you are using?
Have you tried PX2 nvmedia demo, such as nvmipp_raw? Does it also has the same issue?

Hi Wing,

First of all thanks for the really quick reply!

We are using PDK 5.05b.

nvmipp_raw has the same issue but if you are trying to reproduce the problem you need to start and restart the application a number of times (maybe 20???) before it stops working.


Hi Jamie,

Thanks for the information.

We have reporduced this issue, and will work with NVIDIA to fix this issue, but I think this will need some time since we should get some documents and resource from NVIDIA.

By the way, if you have any clue, please share with us.

Hi Wing,

Thanks for letting us know.

Regarding any ideas, unfortunately since we don’t have access to the DriveWorks source code this is really hard for us to investigate further.

All the best,

Hi, I am going to buy a LI-AR0231-GMSL-R7-200H camera, is this problem solved?

Hi Sarveshd,

We have not received this problem again from last year.

Hi Wing,

Just to clarify, does this mean the problem is solved or are you just ignoring it?

Many thanks,

Hi jamie.tattersall,

We don’t have PX2 to do the testing at this moment. Actually, we mainly focus on Nvidia Jetson platform and don’t have driver code access of the Drive platform. If you still have the same issue with the latest PDK, It seems that there is no solution yet.
However, we don’t receive the similar feedback from other customers yet.