error loading shared libraries

With a fresh Ubuntu 14 and a fresh DriveInstall.

When /usr/local/driveworks/bin/sample_hello_world is executaded the following error is obtained:
error loading shared libraries

Should I add to the path?

Dear amb2,
Please add CUDA lib to LD_LIBRARY_PATH

Hello Siva

I have the same problem, I added the cuda lib to LD_LIBRARY_PATH
by adding following line to .bashrc
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/cuda-10.2
still doesn’t work.

I’ve tried changing the path: /home/aceinna/nvidia/nvidia_sdk/DRIVE_Software_10.0_Linux_OS_DDPX/DRIVEOS/drive-t186ref-linux/lib-target

it doesn’t work either

Can you please help. I’ve just installed Drive SDK through SDK manager and trying to verify the installation by running ./sample_drivenet

Thanks in advance.

Dear rborad,
Could you check running deviceQuery CUDA sample for verifying if CUDA setup correct?(/usr/local/cuda-10.2/samples/1_Utilities/deviceQuery). It looks like Nvidia drivers are not installed on host. Could you check installing drivers and try again.

Thank you Siva. You are right. It was the driver issue. Thanks you for the reply.