file format not recognized; treating as linker script


I’m trying to compile isaac_ros_visual_slam repository following the instructions, but I’ve got that error:

/usr/bin/ld:/home/dell/ros2_ws_isaac/isaac_ros-dev/src/isaac_ros_nitros/isaac_ros_nitros/gxf/lib/gxf_x86_64_cuda_11_7/core/ file format not recognized; treating as linker script
/usr/bin/ld:/home/dell/ros2_ws_isaac/isaac_ros-dev/src/isaac_ros_nitros/isaac_ros_nitros/gxf/lib/gxf_x86_64_cuda_11_7/core/ syntax error
collect2: error: ld returned 1 exit status
gmake[2]: *** [CMakeFiles/isaac_ros_nitros.dir/build.make:311:] Error 1
gmake[1]: *** [CMakeFiles/Makefile2:139: CMakeFiles/isaac_ros_nitros.dir/all] Error 2
gmake: *** [Makefile:146: all] Error 2
Failed   <<< isaac_ros_nitros [10.4s, exited with code 2]

My configuration is as follow:
Ubuntu 22.04, ROS humble and gcc 11.3.0.

It looks like git-lfs did not materialize the files here. See the following troubleshooting note to resolve: isaac_ros_common/ at main · NVIDIA-ISAAC-ROS/isaac_ros_common · GitHub

Yes git lfs pull solved the problem. Thank you!

Now, I’ve got another error when launching to code:
ros2 launch isaac_ros_visual_slam
That was the error:

[component_container-1] [ERROR] 140239920469312 [CUDA] failure: 803, file: /home/akorovko/Code/elbrus/src/modules/cuda_modules/inc/cuda_helper.h, line: 29
[ERROR] [component_container-1]: process has died [pid 41504, exit code -6, cmd '/opt/ros/humble/lib/rclcpp_components/component_container --ros-args -r __node:=visual_slam_launch_container -r __ns:=/'].

When I try to run the tests, they failed:

-- stderr: isaac_ros_nitros_compressed_image_type                      
Errors while running CTest
Output from these tests are in: /home/dell/ros2_ws_isaac/isaac_ros-dev/build/isaac_ros_nitros_compressed_image_type/Testing/Temporary/LastTest.log
Use "--rerun-failed --output-on-failure" to re-run the failed cases verbosely.

The same error for all isaac_ros_nitros_* related packages.

Should I post that on another thread?

Could you please provide the full stack trace while launching the Isaac ROS Visual SLAM launch file? Additionally, can you give us more information about your graph setup? What camera are you using, and what other nodes are running on the same system?

While the error with isaac_ros_nitros_compressed_image_type is something we’ll look into separately, it should not be at all related to the Visual SLAM error you observed.

It works now, I had to clean my build folders. Thank you.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.