libhighgui-dev opencv dependency?

I’m trying to build an application that requires libhighgui-dev,
what am I not understanding?

when I try to install libhighgui-dev, the dependencies include a mass of opencv and other** stuff:
libopencv-core-dev libopencv-core2.4 libopencv-highgui-dev libopencv-highgui2.4 libopencv-imgproc-dev libopencv-imgproc2.4

are these not included in the nvidia opencv build?
or what have I not done?

I’d prefer not to build opencv from source if possible.

thanks again

~:"

**

$ sudo apt-get install libhighgui-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following extra packages will be installed:
gir1.2-gtk-2.0 libatk1.0-dev libavcodec-dev libavformat-dev libavutil-dev
libcairo-script-interpreter2 libcairo2-dev libdc1394-22-dev libexpat1-dev
libfontconfig1-dev libgdk-pixbuf2.0-dev libglib2.0-dev libgtk2.0-dev
libharfbuzz-dev libharfbuzz-gobject0 libilmbase-dev libilmbase6
libjasper-dev libopencv-core-dev libopencv-core2.4 libopencv-highgui-dev
libopencv-highgui2.4 libopencv-imgproc-dev libopencv-imgproc2.4
libopenexr-dev libopenexr6 libpango1.0-dev libpcre3-dev libpcrecpp0
libpixman-1-dev libraw1394-dev libraw1394-tools libswscale-dev
libxcb-shm0-dev libxcomposite-dev libxcursor-dev libxft-dev libxinerama-dev
libxml2-utils pkg-config x11proto-composite-dev x11proto-xinerama-dev
Suggested packages:
libgsm1-dev libogg-dev libschroedinger-dev libspeex-dev libtheora-dev
libvorbis-dev libcairo2-doc libglib2.0-doc libgtk2.0-doc libpango1.0-doc
imagemagick libraw1394-doc
The following NEW packages will be installed:
gir1.2-gtk-2.0 libatk1.0-dev libavcodec-dev libavformat-dev libavutil-dev
libcairo-script-interpreter2 libcairo2-dev libdc1394-22-dev libexpat1-dev
libfontconfig1-dev libgdk-pixbuf2.0-dev libglib2.0-dev libgtk2.0-dev
libharfbuzz-dev libharfbuzz-gobject0 libhighgui-dev libilmbase-dev
libilmbase6 libjasper-dev libopencv-core-dev libopencv-core2.4
libopencv-highgui-dev libopencv-highgui2.4 libopencv-imgproc-dev
libopencv-imgproc2.4 libopenexr-dev libopenexr6 libpango1.0-dev libpcre3-dev
libpcrecpp0 libpixman-1-dev libraw1394-dev libraw1394-tools libswscale-dev
libxcb-shm0-dev libxcomposite-dev libxcursor-dev libxft-dev libxinerama-dev
libxml2-utils pkg-config x11proto-composite-dev x11proto-xinerama-dev
0 upgraded, 43 newly installed, 0 to remove and 0 not upgraded.
Need to get 3,141 kB/13.3 MB of archives.
After this operation, 60.5 MB of additional disk space will be used.

Why do you need to install “libhighgui-dev”? If you follow the OpenCV tutorial (http://elinux.org/Jetson/Tutorials/OpenCV), you will have HighGUI installed on your system as part of OpenCV4Tegra.

Hello,

I think my problem is related to the one Peepocom is having. I get a similar output when trying to install a package with APT, that depends on libopencv-dev.

Although I have installed OpenCV4Tegra-dev, apt-get tries to install libopencv-dev, causing a conflict.

Take a look at my post.