LicensePlateDetection - subprocess-exited-with-error

Description

While working on the tao_deploy on Colab and in the cell 5, I could not build wheel for “cuda” and for “pycocotools”, which are required to install pyproject.toml-based projects

Environment

Google Colab

Is it running nvidia-tao/tao_deploy/tao_deploy.ipynb at main · NVIDIA-AI-IOT/nvidia-tao · GitHub?

Could you please save as a copy of .ipynb and then upload it?

Yes, I was working on this notebook, I tried to install the pycocotools from the github repo, and I installed pycuda with pip, and the installation was successful , but then when I wanted to install nvidia-tao I kept getting the same errors

Do you mean when you try to run step to step according to nvidia-tao/tao_deploy/setup_env_colab.sh at main · NVIDIA-AI-IOT/nvidia-tao · GitHub but get error when install nvidia-tao?

Yes exactly, I don’t know if it’s related to dependencies version conflicts or something else.

Please try if below helps.

   $  pip install Cython==0.29.36
   $  sudo apt install libopenmpi-dev
   $  pip install mpi4py

Refer to NVIDIA-TAO-Deploy -pycocotools-fix issue - Python Wheels TAO implementation porting from Collab to AWS SageMaker Studio - #9 by Morganh.