LIDAR Troubleshooting: Setting up the Quanergy M81 Rev C1 with the DPX2

I am trying to set up a a Quanergy M8-1 Rev. C1. LIDAR with the DRIVE PX2 and following docs and guides, I ran the following on a terminal -

INPUT:
ubuntu@tegra-ubuntu:/usr/local/driveworks-0.2.1/bin$ ./sample_lidar_replay --ip=10.24.250.171 --port=7780 --device=QUAN_M81A --scan-frequency=10

OUTPUT:
Program Arguments:
–device=QUAN_M81A
–file=…/./data/samples/sensors/lidar/lidar_sample.bin
–ip=10.24.250.171
–offscreen=0
–port=7780
–scan-frequency=10

nvrm_gpu: Bug 1781434 workaround enabled.
nvrm_gpu: Bug 1778448 workaround enabled.
Initialize DriveWorks SDK v0.2.1
Release build with GNU 4.9.2 from v0.2.1-rc6-0-g684729c against PDK v4.1.4.0
SDK: no resource mounted
SDK: Create NvMediaDevice
egl::Display: found 2 EGL devices
egl::Display: use drm device: drm-nvdc
SAL: identified board as DrivePX2-TegraA
SensorFactory::createSensor() -> lidar.socket, ip=10.24.250.171,port=7780,device=QUAN_M81A,scan-frequency=10
LidarSocket: connected to 10.24.250.171:7780
LidarSocket: Device disconnected <<--------- HERE IT GETS DISCONNECTED
SDK: Release NvMediaDevice
Driveworks SDK released

It seems the LIDAR connects to the DPX2 for a short while, the point cloud window gets displayed as well (but just the GUI, no point cloud is actually displayed even though the LIDAR is powered on and running) and then suddenly gets disconnected (I don’t seem to understand why this keeps happening). I have tried connected the LIDAR’s ethernet cable to the blue Gigabit ethernet port on the DPX2, that’s on the Vehicle cable harness and also to the common network switch that the Drive PX2 is connected to.

My LIDAR has a Dynamic IP: 10.24.250.171 (port: 7780) (scan-frequency: 10)
The Drive PX2 also has been assigned a Dynamic IP: 10.24.250.207

Please help me resolve this issue, also, if any docs or guides are referred to, please provide me with the exact link or location where I can find those docs/guides (be it on the driveworks folder or online).

I have already looked at usr/local/driveworks-0.2.1/doc/nvdwx_html/dwx_lidar_replay_sample.html apart from several other guides and docs, and there are no troubleshooting steps mentioned there for this issue that I am facing right now.

Also, I would like to know if this LIDAR is supported with the DPX2 in the first place. The DriveWorks SDK Reference 0.2.1 Release states that the currently supported Quanergy device is the Quanergy M8 [QUAN_M81A]. Is this the same one as the Quanergy M8-1 Rev. C1?

Thanks.

Dear Vizer1993,

Please see below link, maybe this topic is same issue. Thanks.
https://devtalk.nvidia.com/default/topic/1022829/drive-hardware/setting-up-quanergy-m8-1-rev-c1-lidar-with-the-drive-px2/