LightBoost (for 2D) under Linux?

Hi!

I’m not interested in 3D at all, but the backlight strobing offered by
LightBoost could finally give TFTs a performance comparable to CRTs,
regarding depiction of motion, by simulating a CRT’s pulse-type display
(instead of the normal hold-type of TFTs).

Therefore, I’m considering buying a LightBoost compatible
120 Hz monitor, namely one of these:

  • Asus VG248QE
  • Asus VG278HE
  • Acer HN274HBbmiiid
  • BenQ XL2411T
  • BenQ XL2420T

My two questions are:

  • Can I arbitrarily (e.g. by means of a small script) switch LightBoost on and off in Linux, and if so, [b]how would I do that?[/b] My monitors run constantly at 120 Hz, both for desktop and for games like UrbanTerror (no 3D mode, only 2D).

    Note that
    ftp://download.nvidia.com/XFree86/Linux-x86/313.18/README/README.txt
    doesn’t even contain the word LightBoost.

  • Any limitations with activated LightBoost? Like no possibility to adjust brightness etc.?

Graphics card is a passively cooled Gigabyte 9800 GT Silent Cell.
I will buy a GTX 650 for a second computer, as soon as passively
cooled models of it are available.

Thanks in advance for your answer!

OmiGosh

Hello,

I think this would get answered faster (or at all) at a Linux community of the distro you are using. Ubuntu forums is a great place to start, but if you use Linux Mint check out their forums here, and for Kubuntu here.

You should always, I’m pretty sure, be able to change brightness levels through the driver settings of your card or through the Display settings native to the OS you are using.

Wow, I would have expected this could best be answered by the
makers of the Nvidia drivers … ok, I’ll give it a shot at
the forums for Debian and others, thanks!

About being able to set the brightness in 120 Hz (“3D”) mode:

That is often disabled (I guess it could interfere with the
shutter glasses synchronization or something, and therefore
could introduce or amplify ghosting or similar), as it was
the case with my Samsung 2233RZ and older versions of the
Nvidia driver. Thank $DEITY, there is “ddccontrol”, so back
then, I could route around the artificial restriction (IIRC).
Nowadays, with newer Nvidia drivers, the OSD settings are
not locked anymore – at least with my current 9800 GT, maybe
the locking also depended on the graphics card model.

What’s new with lightboost on linux? Did something changed ?
I still don’t know how to enable lightboost on ubuntu.

I’ve looked whole internet already.

In principle, it is easy to transfer the “hacks” that float around for Windows to Linux: Just add and activate the correct video mode. 'Course, the devil is in the details and so that others do not have to go through all of the log and manual reading, I’ve written the process up here:

http://forums3.armagetronad.net/viewtopic.php?f=1&t=23173

(Posting here because I found myself in the same situation as the previous poster and google search lead me here and basically no other relevant place.)

And to the specific questions, in case they still matter:
Yes, switching it on and off via script can work; I personally simply use xrandr to change the refresh rate. 144 Hz for non-LightBoost, 120 Hz for Lightboost. I did not manage to convince xrandr to add two 120 Hz modes to its list under different names. It should be possible, I probably just was not stubborn enough. If all else fails, you could switch your desktop to 119 Hz, or use the nvidia-xconfig tool; it does allow switching between two 120 Hz modes.

Brightness: For me (Asus VG248QE), the regular brightness control on the monitor is blocked, as are all other picture adjustments one would care about except contrast. The LightBoost control does give limited brightness control, though. For me, the lowest setting is still a bit too bright for desktop work (games are fine), but that may very well be because my home workspace is a practically unlit corner. Need to install a lamp.

I got LightBoost to work in Linux, but it is very convoluted. The reason is that LightBoost is a DDC protocol with a special encrypted nVidia lock. These steps worked for me:

  1. Boot to Windows (temporarily).
  2. Enable LightBoost (either by connecting a 3D Vision Kit, or by following the LightBoost HOWTO)
  3. Reboot to Linux (do NOT unplug monitor’s power supply).
  4. LightBoost will go away, but the LightBoost feature is still unlocked inside monitor.
  5. Load a custom 1080p modeline with a Vertical Total of 1149 (vsync + front porch + back porch + vertical resolution of 1080).
  6. Disable validation (AllowNonEdidModes)
  7. Switch to the custom modeline.
  8. LightBoost re-enables immediately in Linux. Yay!

This is a picture of the LightBoost compatible numbers you will need to add to your custom modeline:
http://www.blurbusters.com/wp-content/uploads/2013/02/toastyx.jpeg

Now, Z-Man’s link has better instructions, far more detailed than the above.
HOWTO: Enable LightBoost under Linux
I think that is the better set of instructions.

But you do need to do a one-time unlocking of LightBoost first. LightBoost behaves this way because it’s a locked/encrypted feature in a LightBoost monitor that requires nVidia drivers to unlock. They did this to prevent AMD from being able to use this feature. Fortunately – for most LightBoost monitors – once this one-time step is done, it’s unlocked until you unplug your monitor.

I can’t boot to windows and wont install it principally.
So I still with no way to enable lightboost :(

But guys, if you have a way to enable nvidia drivers in windows liveusb version (Windows 7 PE or something like it) - please write here. Because I couldn’t do that.

You can enable LightBoost with a different computer (even an nVidia laptop).
Then hotplug the DVI cable, without unplugging the monitor’s power.

There are also easier solutions coming, if you want to wait longer.

Been waiting a while! Still no solution. :(