LimeSDR with GNURadio on Jetson TX2

Before I express some personal difficulties, I will say that I think there is very little information on the web about running this hardware/software combination. I would like to initiate this forum topic in hopes of consolidating efforts for those who also share interest.

I just recently purchased a LimeSDR USB board and would like to connect it to my Jetson TX2. Following the downloads section for Ubuntu (, I’m to add two PPAs to the system via

sudo add-apt-repository ppa:myriadrf/drivers
sudo apt-get update


sudo add-apt-repository ppa:myriadrf/gnuradio
sudo apt-get update

The /etc/apt/sources.list.d directory file listing contains:

-rw-r--r-- 1 root root  134 Aug 10 12:00 myriadrf-ubuntu-drivers-xenial.list
-rw-r--r-- 1 root root  278 Aug 10 11:59
-rw-r--r-- 1 root root  136 Aug 10 12:00 myriadrf-ubuntu-gnuradio-xenial.list
-rw-r--r-- 1 root root  138 Aug 10 11:59

The contents of myriadrf-ubuntu-drivers-xenial.list are:

deb xenial main
deb-src xenial main

and the contents of myriadrf-ubuntu-gnuradio-xenial.list are:

deb xenial main
deb-src xenial main

I believe I have the sources correctly defined. I then proceed to install Lime Suite following the instructions for Ubuntu ( The first instruction following the PPA setup is:

sudo apt-get install limesuite liblimesuite-dev limesuite-udev limesuite-images

and I get the following output

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package limesuite
E: Unable to locate package liblimesuite-dev
E: Unable to locate package limesuite-udev
E: Unable to locate package limesuite-images

I even tried to use Synaptic Package Manager to find the packages provided by the PPA source and none of those above are listed. I definitely did sudo apt-get update after adding the PPA sources and I even restarted the computer. I’ve tried everything I can think of, but I don’t understand why I can’t locate the necessary files.

Digging into the package details for the drivers ( I can see that the contents of “limesuite -” contains the build packages I’m looking for. I did notice under “Builds” it says:


Issuing the command lscpu on the Jetson gives:

Architecture:          aarch64
Byte Order:            Little Endian
CPU(s):                6
On-line CPU(s) list:   0,3-5
Off-line CPU(s) list:  1,2
Thread(s) per core:    1
Core(s) per socket:    4
Socket(s):             1
Model name:            ARMv8 Processor rev 3 (v8l)
CPU max MHz:           2035.2000
CPU min MHz:           345.6000
Hypervisor vendor:     horizontal
Virtualization type:   full
L1d cache:             32K
L1i cache:             48K
L2 cache:              2048K

Of main interest here is the architecture aarch64, which is not listed as a supported build under the PPA. This makes me believe I have to build everything from source?

OK, so there is an “install from source” option shown on the installation page, but one of the key hardware support dependencies is libsoapysdr-dev, which I can not find.

Why are none of the package files contained in the PPA showing up on my system? Is it because of the architecture? Or is there something special about the way the Jetson handles PPAs?

I’m starting to feel like a clean installation is going to be more difficult than anticipated. So my question is, has anyone installed a LimeSDR on the Jetson TX2 (including drivers and GNURadio)? If so, I could use some guidance on how to get everything up and running. I can probably hack my way through, but I would rather travel a path well known.

Some system info (if I recall, installed via JetPack 3.2.1):

lsb_release -a 
Description:	Ubuntu 16.04.5 LTS
Release:	16.04
Codename:	xenial
head -1 /etc/nv_tegra_release
# R28 (release), REVISION: 2.1, GCID: 11272647, BOARD: t186ref, EABI: aarch64, DATE: Thu May 17 07:29:06 UTC 2018

Hello. Have you succeeded in connecting LimeSDR to Jetson TX2? I’ve built LimeSuite using official documentation. But first you have also build SoapySDR.

No I haven’t. Do you have a write up some where on what you did? Or maybe you can point to some references?