Linking error cannot find -lsamples_allocator

Whilst upgrading existing code from OS8 to OS10, we have worked through the Nvidia Porting Guide, and resolved the compilation errors that occurred in the OS8 code.

The Cmake command works fine without errors.
When we try to follow it up with “make -j”, it throws an error “cannot find -lsamples_allocator”.

Google as well as the search function on this forum does not return any results if we search for “lsamples_allocator”, and we have not heard of it before either.

We’d like some help resolving this, as we’re currently stumped.

Hi Rschiltkamp,

Is “make samples_allocator” working on your side?

The “make samples_allocator” in the driveworks/samples folder is executing correctly.
In our project folder, it throws the error that samples_allocator doesnt exist

Please refer to below driveworks sample source for fixing your issue. Thanks!

/usr/local/driveworks/samples/src/framework/Allocator.cpp
/usr/local/driveworks/samples/src/framework/CMakeLists.txt

We’ve solved it by copying the samples_allocator folder from driveworks/framework to our source, and adding it to the make file as depencency.

Thanks!